Project

General

Profile

Bug #8393

IPAlias VIPs on localhost are not applied at boot.

Added by Steve Wheeler over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Virtual IPs
Target version:
Start date:
03/29/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.3
Affected Architecture:
All

Description

An VIP configured like:

<vip>
    <mode>ipalias</mode>
    <interface>lo0</interface>
    <uniqid>5abd4e7832f51</uniqid>
    <descr><![CDATA[Test on lo0]]></descr>
    <type>single</type>
    <subnet_bits>32</subnet_bits>
    <subnet>192.168.0.1</subnet>
</vip>

Is not present after booting:

[2.4.3-RELEASE][admin@apu.stevew.lan]/root: ifconfig lo0
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4 
    inet 127.0.0.1 netmask 0xff000000 
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    groups: lo 

But after resaving the VIP via the GUI is added:

[2.4.3-RELEASE][admin@apu.stevew.lan]/root: ifconfig lo0
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4 
    inet 127.0.0.1 netmask 0xff000000 
    inet 192.168.0.1 netmask 0xffffffff 
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    groups: lo 

It does not affect other real interfaces.

Associated revisions

Revision 52d4dc91 (diff)
Added by Luiz Souza over 1 year ago

Fixes a bug where an IP alias on loopback interface is not initialized at boot.

A recent change changed the IP alias setup to only happen on enabled interfaces. As the loopback interfaces do not have the enabled flag on config there are being skiped.

While here reduce some duplicate code and apply the same rules for VIPs and IP aliases.

Ticket: #8393
Github PR: #3920

Revision ec203c03 (diff)
Added by Luiz Souza over 1 year ago

Fixes a bug where an IP alias on loopback interface is not initialized at boot.

A recent change changed the IP alias setup to only happen on enabled interfaces. As the loopback interfaces do not have the enabled flag on config there are being skiped.

While here reduce some duplicate code and apply the same rules for VIPs and IP aliases.

Ticket: #8393
Github PR: #3920

(cherry picked from commit 52d4dc91613d8cd6bdb7eca0a26cec2b802a0046)

Revision b0ad46aa (diff)
Added by Luiz Souza over 1 year ago

Fixes a regression in my previous commit.

IP aliases can be used with CARP vhids too.

Reported by: PiBa
Ticket: #8393

Revision 36c029a1 (diff)
Added by Luiz Souza over 1 year ago

Fixes a regression in my previous commit.

IP aliases can be used with CARP vhids too.

Reported by: PiBa
Ticket: #8393

(cherry picked from commit b0ad46aa32c6ffc7d3d2e25a2b918de8dd9fa2f4)

History

#1 Updated by Pi Ba over 1 year ago

I've noticed that to, can you try the patch?: https://github.com/pfsense/pfsense/pull/3920

#2 Updated by James Dekker over 1 year ago

We're testing the patch now.

Patch resolves the issue.

#3 Updated by Steve Wheeler over 1 year ago

That works here.

#4 Updated by Andy Kniveton over 1 year ago

Works fine for me too, no need to go back into the VIPs and resave.

#5 Updated by James Dekker over 1 year ago

  • Status changed from New to Assigned
  • Assignee set to Luiz Souza

#6 Updated by Jim Pingle over 1 year ago

  • Status changed from Assigned to Feedback

#7 Updated by Pi Ba over 1 year ago

Seems now a IPalias under a CARP parent is not applied.?

#8 Updated by Luiz Souza over 1 year ago

Can you please elaborate PiBa ?

#9 Updated by Pi Ba over 1 year ago

Hi Luiz,

To have multiple highly available IP's on 1 interface its possible to configure a vip of type "alias" and choose as the interface a vip that has the type "CARP" while that CARP ip is for example on the interface LAN.

        <vip>
            <mode>ipalias</mode>
            <interface>_vip57e6821202aca</interface>
            <uniqid>57e68233b6130</uniqid>
            <descr><![CDATA[This is a IPalias with a CARP parent]]></descr>
            <type>single</type>
            <subnet_bits>24</subnet_bits>
            <subnet>192.168.0.202</subnet>
        </vip>

#10 Updated by Luiz Souza over 1 year ago

I forgot about these, I had the 'CARP isn't a interface anymore' thinking in my head.

Should be fixed now.

Thanks!

#11 Updated by Pi Ba over 1 year ago

Works for me. Thanks Luiz!

#12 Updated by Luiz Souza over 1 year ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

#13 Updated by Jim Pingle over 1 year ago

  • Target version changed from 2.4.4 to 2.4.3-p1

Also available in: Atom PDF