Project

General

Profile

Bug #8556

Notification always sent twice via email - DynDNS updated IP Address on WAN (pppoe0) to

Added by Willy Tenner about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
-
Start date:
06/07/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.3
Affected Architecture:
amd64

Description

When I get a new IP from my provider I always get two emails with same content about this event. E.g.

Notifications in this message: 1
================================

1:51:39 DynDNS updated IP Address on WAN (pppoe0) to 87.188.204.91

The log entries of notify_monitor.php shows this:

May 25 01:51:40 pfsense php-cgi: notify_monitor.php: Message sent to message.pfsense@mail.delikom.de OK
May 25 01:51:50 pfsense php-cgi: notify_monitor.php: Message sent to message.pfsense@mail.delikom.de OK

10 seconds later a second email was sent with same content.

Is this normal behaviour?

History

#1 Updated by Jim Pingle about 2 years ago

  • Category set to Dynamic DNS
  • Status changed from New to Closed

I can't reproduce this here, I only get one e-mail per message even from Dynamic DNS updates. It may be specific to something happening on your WAN or your Dynamic DNS provider.

Please start a thread on https://forum.netgate.com or https://reddit.com/r/pfsense/ so we can discuss this more in-depth and determine where the problem may be. If we can identify a specific bug, then we can reopen this issue. In the thread, please include more detail, such as:

Does this only happen with the DynDNS log message? Or with other notices?
Are other messages from DynDNS logged multiple times?
Are there any other log messages in the system log or other logs at the same time as both of those messages?

Also available in: Atom PDF