Project

General

Profile

Bug #8603

PPP WANs do not work on VLANs on current snapshots

Added by Jim Pingle over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Very High
Assignee:
Category:
Interfaces
Target version:
Start date:
06/27/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
All

Description

At some time between April and now on 2.4.4 snapshots, PPP WANs like PPPoE stopped working when using a VLAN interface.

Jun 27 09:54:35 jack kernel: ng0: changing name to 'pppoe0'
Jun 27 09:54:35 jack ppp: [opt4_link0] LCP: Open event
Jun 27 09:54:35 jack ppp: [opt4_link0] LCP: state change Initial --> Starting
Jun 27 09:54:35 jack ppp: [opt4_link0] LCP: LayerStart
Jun 27 09:54:35 jack ppp: [opt4_link0] PPPoE: Connecting to ''
Jun 27 09:54:35 jack kernel: ng_ether_attach: can't name node re1_30

At that point it falls into a loop where it times out over and over.

Relevant portions of config.xml:

    <interfaces>
        <opt4>
            <descr><![CDATA[PWAN]]></descr>
            <if>pppoe0</if>
            <enable></enable>
            <spoofmac></spoofmac>
            <ipaddr>pppoe</ipaddr>
        </opt4>
    </interfaces>
    <vlans>
        <vlan>
            <if>re1</if>
            <tag>30</tag>
            <pcp></pcp>
            <descr><![CDATA[PPPoE Test]]></descr>
            <vlanif>re1.30</vlanif>
        </vlan>
    </vlans>
    <ppps>
        <ppp>
            <ptpid>0</ptpid>
            <type>pppoe</type>
            <if>pppoe0</if>
            <ports>re1.30</ports>
            <username>jack</username>
            <password>amFjaw==</password>
            <descr><![CDATA[PPPoE Test]]></descr>
            <bandwidth></bandwidth>
            <mtu></mtu>
            <mru></mru>
            <mrru></mrru>
            <provider></provider>
        </ppp>
    </ppps>

/var/etc/mpd_opt4.conf

startup:
    # configure the console
    set console close
    # configure the web server
    set web close

default:
pppoeclient:
    create bundle static opt4
    set bundle enable ipv6cp
    set iface name pppoe0
    set iface disable on-demand
    set iface idle 0
    set iface enable tcpmssfix
    set iface up-script /usr/local/sbin/ppp-linkup
    set iface down-script /usr/local/sbin/ppp-linkdown
    set ipcp ranges 0.0.0.0/0 0.0.0.0/0
    #log -bund -ccp -chat -iface -ipcp -lcp -link

    create link static opt4_link0 pppoe
    set link action bundle opt4
    set link disable multilink
    set link keep-alive 10 60
    set link max-redial 0
    set link disable chap pap
    set link accept chap pap eap
    set link disable incoming
    set link mtu 1492
    set auth authname "jack" 
    set auth password jack
    set pppoe service "" 
    set pppoe iface re1.30
    open

History

#1 Updated by Jim Pingle over 1 year ago

Similar to #7981

#2 Updated by Dirk Steingäßer over 1 year ago

Hi, any news here? Best regards

#3 Updated by Josiah Whitefield over 1 year ago

I fixed this temporarily by editing the vlans to <vlanif>re1_30</vlanif>
Replaced the "." to "_" this was an issue when moving from version 2.3 to 2.4 also I think.

#4 Updated by Dirk Steingäßer over 1 year ago

Ok thanks a lot for that hint

#5 Updated by Dirk Steingäßer over 1 year ago

So i tested to change manually <vlanif>re1_30</vlanif> by replacing "." to the "_" but it does not resolve the symptom.

#6 Updated by Josiah Whitefield over 1 year ago

sorry that didnt work, what if you try replace all instances of re1.30 with re1_30
it is also listed under ppp

#7 Updated by Dirk Steingäßer over 1 year ago

Sorry that did not work at all in my case. I had some trouble after changing the config.xml manually and needed to restore the system. So touching it seems to be not good in my case... Since that bug seems not so difficult to solve btw it is already solved in the past, i'm looking forward to have a fix in the short term

#8 Updated by Jim Pingle over 1 year ago

  • Assignee set to Luiz Souza

This is still a problem on current snapshots in certain circumstances. There is no current viable workaround, but it will be addressed soon.

Do not attempt to edit any files or make config.xml changes to fix it, you may unintentionally break other things and/or mask the real problem.

#9 Updated by Enzo Laroche over 1 year ago

Reverting to an older kernel solved it for me

#10 Updated by Dirk Steingäßer over 1 year ago

Yeah.... but that's not the way to fix bugs ;)

#11 Updated by Enzo Laroche over 1 year ago

No, but it shows that a newer build works with an older kernel. So it's not a configuration or a package issue.

#12 Updated by Dirk Steingäßer over 1 year ago

The ticket is now 28 days old and it is a serious issue but already solved in the past. How is the progress with it?

#13 Updated by Steve Beaver over 1 year ago

  • Status changed from New to This Sprint

#14 Updated by Steve Beaver over 1 year ago

  • Status changed from This Sprint to New

#15 Updated by Luiz Souza about 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Fix upstreamed and merged to 2.4.4 branch.

https://svnweb.freebsd.org/base?view=revision&revision=337844

#16 Updated by Jim Pingle about 1 year ago

  • Status changed from Feedback to This Sprint

This still does not appear to be working, my PPPoE on VLAN test still fails. The ng_ether_attach error is gone, but the connection still fails.

Aug 17 09:20:07 jack ppp: process 26346 started, version 5.8 (nobody@pfSense_master_amd64-pfSense_devel-job-04 11:02  3-Aug-2018)
Aug 17 09:20:07 jack ppp: web: web is not running
Aug 17 09:20:07 jack ppp: [opt4] Bundle: Interface ng0 created
Aug 17 09:20:07 jack ppp: [opt4_link0] Link: OPEN event
Aug 17 09:20:07 jack ppp: [opt4_link0] LCP: Open event
Aug 17 09:20:07 jack ppp: [opt4_link0] LCP: state change Initial --> Starting
Aug 17 09:20:07 jack ppp: [opt4_link0] LCP: LayerStart
Aug 17 09:20:07 jack ppp: [opt4_link0] PPPoE: Connecting to ''
Aug 17 09:20:16 jack ppp: [opt4_link0] PPPoE connection timeout after 9 seconds
Aug 17 09:20:16 jack ppp: [opt4_link0] Link: DOWN event
Aug 17 09:20:16 jack ppp: [opt4_link0] LCP: Down event
Aug 17 09:20:16 jack ppp: [opt4_link0] Link: reconnection attempt 1 in 3 seconds
Aug 17 09:20:19 jack ppp: [opt4_link0] Link: reconnection attempt 1
Aug 17 09:20:19 jack ppp: [opt4_link0] PPPoE: Connecting to ''
Aug 17 09:20:28 jack ppp: [opt4_link0] PPPoE connection timeout after 9 seconds
Aug 17 09:20:28 jack ppp: [opt4_link0] Link: DOWN event
Aug 17 09:20:28 jack ppp: [opt4_link0] LCP: Down event
Aug 17 09:20:28 jack ppp: [opt4_link0] Link: reconnection attempt 2 in 4 seconds
Aug 17 09:20:32 jack ppp: [opt4_link0] Link: reconnection attempt 2
Aug 17 09:20:32 jack ppp: [opt4_link0] PPPoE: Connecting to ''
Aug 17 09:20:41 jack ppp: [opt4_link0] PPPoE connection timeout after 9 seconds

Packet capture shows the request go out and a reply come back, but it's as if the reply never makes it up the stack to mpd

09:37:47.665945 00:0d:b9:33:0f:71 (oui Unknown) > Broadcast, ethertype 802.1Q (0x8100), length 40: vlan 30, p 0, ethertype PPPoE D, PPPoE PADI [Host-Uniq 0xC010CD1500F8FFFF] [Service-Name]
09:37:47.667943 00:0c:29:78:6e:58 (oui Unknown) > 00:0d:b9:33:0f:71 (oui Unknown), ethertype 802.1Q (0x8100), length 78: vlan 30, p 0, ethertype PPPoE D, PPPoE PADO [AC-Name "clara.lab.jimp.pw"] [Service-Name] [Service-Name "*"] [Host-Uniq 0xC010CD1500F8FFFF] [AC-Cookie 0xC0C5A30B00F8FFFF]

#17 Updated by Luiz Souza about 1 year ago

  • Status changed from This Sprint to Feedback

I missed one branch while I was cherry-picking this fix. It will be available on next CE snapshot.

#18 Updated by Jim Pingle about 1 year ago

  • Status changed from Feedback to Resolved

It's working on the latest snapshot, PPPoE connected, interface is up and passing traffic. Thanks!

#19 Updated by Dirk Steingäßer about 1 year ago

I can confirm this too. Many thanks

#20 Updated by Enzo Laroche about 1 year ago

Solved on 2.4.4.a.20180818.2240.
Thanks for fixing this bug.

#21 Updated by Peter Bosgraaf about 1 year ago

Did this fix made it in the 2.4.4 release? I just upgraded to 2.4.4 stock and it looks like i’m hitting this issue, my ppp wont connect over vlan interface anymore.

#22 Updated by Jim Pingle about 1 year ago

Yes, the fix is in release and it is currently working on our test systems. If you still have a problem, start a thread on the forum to discuss it and track down what is happening.

Also available in: Atom PDF