Project

General

Profile

Actions

Bug #8683

closed

Unable to add GIF interface (Hurricane Electric IPv6)

Added by P L almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Gateways
Target version:
Start date:
07/23/2018
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.4
Affected Architecture:
All

Description

From crash report:

[23-Jul-2018 22:38:59 America/New_York] PHP Warning: exec(): NULL byte detected. Possible attack in /etc/inc/util.inc on line 1712
[23-Jul-2018 22:38:59 America/New_York] PHP Warning: exec(): NULL byte detected. Possible attack in /etc/inc/util.inc on line 1712
[23-Jul-2018 22:38:59 America/New_York] PHP Warning: file_put_contents() expects parameter 1 to be a valid path, string given in /etc/inc/interfaces.inc on line 1200

From logs:

/interfaces_gif_edit.php: XML error: Invalid character at line 13772 in /conf/config.xml

Actions #1

Updated by Jim Pingle almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Jim Pingle
  • Target version set to 2.4.4
Actions #2

Updated by Jim Pingle almost 4 years ago

  • Assignee changed from Jim Pingle to Renato Botelho

This appears to be caused by the interface string returned by pfSense_interface_create() which is not a string in the expected format.

config.xml.bad:4681: parser error : Char 0x0 out of allowed range
            <gifif>gif1
                       ^
config.xml.bad:4681: parser error : Premature end of data in tag gifif line 4681
            <gifif>gif1
                       ^
config.xml.bad:4681: parser error : Premature end of data in tag gif line 4673
            <gifif>gif1
                       ^
config.xml.bad:4681: parser error : Premature end of data in tag gifs line 4672
            <gifif>gif1
                       ^
config.xml.bad:4681: parser error : Premature end of data in tag pfsense line 2
            <gifif>gif1
                       ^
var_dump( pfSense_interface_create("gif") );
var_dump( "gif4" );

Outputs:
string(15) "gif4" 
string(4) "gif4" 
Actions #3

Updated by Jim Pingle over 3 years ago

This also affects GRE interfaces

Actions #4

Updated by Jim Pingle over 3 years ago

  • Status changed from Assigned to 13
Actions #5

Updated by Renato Botelho over 3 years ago

  • Assignee changed from Renato Botelho to Anonymous

Steve is working on this one

Actions #6

Updated by Anonymous over 3 years ago

  • Status changed from 13 to Feedback
Actions #7

Updated by Anonymous over 3 years ago

var_dump( pfSense_interface_create("gif"));

Now produces:
string(4) "gif0"
Actions #8

Updated by Jim Pingle over 3 years ago

Result for gre also looks good.

Actions #9

Updated by Anonymous over 3 years ago

  • Status changed from Feedback to Resolved

Tested on 2.4.4-DEVELOPMENT (amd64)
built on Tue Aug 28 08:43:43 EDT 2018
FreeBSD 11.2-RELEASE-p2

Was able to create/edit/delete a GIF interface with no seen errors.

Actions

Also available in: Atom PDF