Project

General

Profile

Bug #8715

System update: Unable to check for updates

Added by Fred Ch over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
Upgrade
Target version:
Start date:
07/29/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:

Description

Issue with last 2 changes to /src/etc/inc/pkg-utils.inc

get_system_pkg_version return false.

reverting to version of pkg-utils.inc of commit:
https://github.com/pfsense/pfsense/commit/71b4b23b15b3ad309147966b6e0035f878724df9#diff-78f869b989e583efac5df0a3826c4a03

Fix the issue.

Associated revisions

Revision e87ea36d (diff)
Added by Renato Botelho over 1 year ago

Revert "Parameter must be an array or 'all'"

Fix #8715 respecting get_pkg_info parameter when it doesn't start with
pfSense-pkg

This reverts commit 70a7c029fbe61935da7474358e7359bb9dc1bcc3.

History

#1 Updated by Tyler L over 1 year ago

I updated from a June build to Sat Jul 28 19:12:21 EDT 2018 build and agree, the GUI Update states: Unable to check for updates. Dropping to shell, pfSense-upgrade and the console option 13, both show no errors though.

#2 Updated by Nick K over 1 year ago

I am having to do the same. Only solution is to roll back to the July 5th commit (below), replace the file on the pfSense instance, and then the update mechanism works correctly.

https://github.com/pfsense/pfsense/commit/71b4b23b15b3ad309147966b6e0035f878724df9#diff-78f869b989e583efac5df0a3826c4a03

#3 Updated by Renato Botelho over 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#4 Updated by Fred Ch over 1 year ago

Latest commit fix the issue.

Thanks

#5 Updated by Renato Botelho over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF