Project

General

Profile

Actions

Bug #8720

closed

restricting packages to official repository

Added by Arthur Wiebe over 3 years ago. Updated over 3 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Package System
Target version:
-
Start date:
07/30/2018
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.4
Affected Architecture:
All

Description

Hey guys, I noticed 3 days ago there was a commit 053182648b676676f9e631eca51c3e5a678344e9 by Renato that restricts the package manager to the official repository.

As you may know we have been relying on being able to use our own repository for our product at dnsthingy.com which is being used by many pfSense customers.

I understand you want to lock down your platform, and as you own it I'm not going to complain, but I want to see what the best path forward is going to be. The way I see it there are 3 basic options.

1. If you would accept, I can contribute a patch for pfSense that has an official method of adding 3rd party repositories from the web UI.

2. Again if you'd be willing to accept, we could contribute our package to pfSense for inclusion in the official repository.

3. We can require our customers to use the command line only for our product installation and treat it as a regular freebsd package.

I'd prefer either 1 or 2, but if you could let me know what option you'd prefer us to take so that we can continue to work with the pfSense community in offering our service.

Thank you.

Actions #1

Updated by Jim Pingle over 3 years ago

  • Status changed from New to Not a Bug

This message will appear in the release notes and explains the change in behavior:

Third party packages from alternate repositories are causing problems for users with the upgrade process and also with post-upgrade behavior. These packages have never been supported, and had to be manually added by users outside of the GUI.

Due to the major changes required for FreeBSD 11.2 and PHP 7.2, third party packages from alternate repositories cannot be present during the upgrade. There is no way to predict if a third party package supports the new version or will cause the upgrade itself to fail.

The upgrade process will automatically remove pfSense-pkg-* packages installed from alternate repositories. After the upgrade completes, the user can reinstall these packages. Packages from alternate repositories will not appear in the Installed Packages list in the GUI, and must be entirely managed in the command line.

This change does not affect packages installed from the official pfSense package repository.

Actions #2

Updated by Arthur Wiebe over 3 years ago

Thanks for the clarification Jim. Do you have a list of requirements for packages being accepted into the pfsense repository?

Actions

Also available in: Atom PDF