Project

General

Profile

Bug #8822

HTTP_REFERER check fails after changing interface IP address

Added by Jim Pingle 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
08/21/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.x
Affected Architecture:
All

Description

If you access the GUI from the LAN and change the LAN interface IP address, then after changing the interface IP address but before applying changes the client will receive an HTTP_REFERER error. The GUI suggests changing the DHCP pool before applying, but that can't be done since the error prevents navigating away from interfaces.php.

Similar to #8524 (same issue but in the wizard)

Associated revisions

Revision 5b93a1f4 (diff)
Added by Jim Pingle 5 months ago

Handle HTTP_REFERER better when changing IP addr. Fixes #8822

Fall back to probing active interface addresses rather than config.xml to allow changed addresses that have not yet been applied.

History

#1 Updated by Jim Pingle 5 months ago

  • Status changed from New to This Sprint

#2 Updated by Jim Pingle 5 months ago

  • Status changed from This Sprint to Feedback
  • % Done changed from 0 to 100

#3 Updated by Azamat Khakimyanov 5 months ago

  • Status changed from Feedback to Resolved

I checked on 2.4.3_p1 - I saw HTTP_REFERER check fails after changing interface IP address
Then I checked it on 2.4.4-DEV (20180825) - and I didn't see that HTTP_REFERER check fail and I was able to press "Apply" button.
But I'm not sure how it helps because you still have to use console access to change DHCP settings for new range or manually set new IP on your PC to access webGUI.

Also available in: Atom PDF