Project

General

Profile

Bug #891

Errors When adding or editing an alias on Pfsense 2.0

Added by robert zelaya over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/14/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

File: firewall_aliases_edit.php

1) pressing enter in the description box deletes the first entry

2) Error correction does not work for (Hosts, ports, networks). Example; page accepts 192.168.1.1s or 192.168.1.1s-192.168.1.22.

3) javascript Timeout error

Associated revisions

Revision 331a89ca (diff)
Added by Erik Fonnesbeck over 8 years ago

Fix the delete button and a couple other small errors. Ticket #891

History

#1 Updated by robert zelaya over 8 years ago

Submitted a 2nd patch for review .

#2 Updated by Erik Fonnesbeck over 8 years ago

The problem with 1) seems to be that the delete button is set as the default button. It deletes the first entry if you press enter with any field selected, but saves when enter pressed if there are no lines to have a delete button.

#3 Updated by Erik Fonnesbeck over 8 years ago

I see what the problem is with 1). The delete button is currently an image button in the form, which I think is treated as a submit button, and therefore the default button. It needs to be an <a href><img /></a> Refer to the HTML for the plus button.

#4 Updated by Erik Fonnesbeck over 8 years ago

I've fixed 1) and 3), but 2) will probably be difficult to fix without blocking some legitimate hosts, since this does not only deal with IP addresses.

#5 Updated by Chris Buechler over 8 years ago

  • Status changed from New to Resolved

The examples given for 2) while probably a typo is a legit hostname, we can't do anything about that one without blocking legit data. The rest looks good.

Also available in: Atom PDF