Project

General

Profile

Actions

Bug #8923

closed

Very long boot delays if WAN interface address not available

Added by Brian Candler about 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
09/20/2018
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

This is with SG-3100 appliance, 2.4.3p1

For testing purposes, I want to restore config from XML where the WAN interface is not actually correct for this network, and then tweak it. (The config is backed up from a data centre, and I want to restore it onto a desktop appliance for testing config changes).

So I connected to 192.168.1.1, restored configuration, and rebooted.

Unfortunately the bootup hangs for several minutes each at many different points:

...
Starting DHCP service...done.
Configuring firewall......done.
Starting SNMP daemon... done.
Generating RRD graphs...done.
Waiting for Internet connection to update pkg metadata and finish package reinstallationUpdating pfSense-core repository catalogue...
<< hang >>
repository pfSense-core has no meta file, using default settings
Unable to update repository pfSense-core
Updating pfSense repository catalogue...
<< hang >>
repository pfSense has no meta file, using default settings
<< hang >>
Unable to update repository pfSense
Error updating repositories!

ERROR!!! An error occurred on pkg execution (rc = 70) with parameters 'update -f':
pkg-static: https://firmware.netgate.com/pkg/pfSense_factory-v2_4_3_armv6-core/meta.txz: No address record
pkg-static: https://firmware.netgate.com/pkg/pfSense_factory-v2_4_3_armv6-core/packagesite.txz: No address record
pkg-static: https://firmware.netgate.com/pkg/pfSense_factory-v2_4_3_armv6-pfSense_factory-v2_4_3/meta.txz: No address record
pkg-static: https://firmware.netgate.com/pkg/pfSense_factory-v2_4_3_armv6-pfSense_factory-v2_4_3/packagesite.txz: No address record

.Updating pfSense-core repository catalogue...
<< hang >>
repository pfSense-core has no meta file, using default settings
<< hang >>
Unable to update repository pfSense-core
Updating pfSense repository catalogue...
<< hang >>
repository pfSense has no meta file, using default settings
<< hang >>
Unable to update repository pfSense
Error updating repositories!

ERROR!!! An error occurred on pkg execution (rc = 70) with parameters 'update -f':
pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
pkg-static: https://firmware.netgate.com/pkg/pfSense_factory-v2_4_3_armv6-core/meta.txz: No address record
pkg-static: https://firmware.netgate.com/pkg/pfSense_factory-v2_4_3_armv6-core/packagesite.txz: No address record
pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
pkg-static: https://firmware.netgate.com/pkg/pfSense_factory-v2_4_3_armv6-pfSense_factory-v2_4_3/meta.txz: No address record
pkg-static: https://firmware.netgate.com/pkg/pfSense_factory-v2_4_3_armv6-pfSense_factory-v2_4_3/packagesite.txz: No address record

.Updating pfSense-core repository catalogue...
<< hang >>

After about half an hour of this I gave up.

The reset button on the SG-3100 causes an immediate reboot, but I can't see a way to use it to clear the saved config. So the primary way I have to recover from this is:

- reflash the SG-3100 firmware entirely (!)
- manually modify the XML to include a usable WAN configuration
- restore the modified XML

It would be very helpful if pfSense could skip over these WAN connectivity problems; or I could have a way to force it to go straight to the configuration menu, so that I could change the WAN IP address and then reboot.

Actions #1

Updated by Jim Pingle about 3 years ago

  • Status changed from New to Duplicate

Duplicate of #7604 which is fixed in 2.4.4.

Actions

Also available in: Atom PDF