Project

General

Profile

Bug #8984

stunnel: Illegal string offset and other PHP hiccups (due to PHP upgrade)

Added by L H 9 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
stunnel
Target version:
-
Start date:
10/01/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.x
Affected Architecture:
All

Description

The last major upgrade of the PHP packages caused this:

Crash report begins.  Anonymous machine information:

amd64
11.2-RELEASE-p4
FreeBSD 11.2-RELEASE-p4 #24 021c0c7c1ad(RELENG_2_4_4): Mon Oct  1 01:25:55 EDT 2018     root@buildbot3:/crossbuild/ce-master/obj/amd64/9kCJYnqE/crossbuild/ce-master/pfSense/tmp/FreeBSD-src/sys/pfSense

Crash report details:

PHP Errors:
[01-Oct-2018 13:16:09 Etc/UTC] PHP Warning:  Illegal string offset 'config' in /usr/local/pkg/stunnel.inc on line 42
[01-Oct-2018 13:16:09 Etc/UTC] PHP Warning:  Invalid argument supplied for foreach() in /usr/local/pkg/stunnel.inc on line 49
[01-Oct-2018 13:20:16 Etc/UTC] PHP Warning:  Illegal string offset 'config' in /usr/local/pkg/stunnel.inc on line 42
[01-Oct-2018 13:20:16 Etc/UTC] PHP Warning:  Invalid argument supplied for foreach() in /usr/local/pkg/stunnel.inc on line 49

No FreeBSD crash data found.

History

#1 Updated by Jim Pingle 9 months ago

  • Category set to stunnel
  • Assignee set to Steve Beaver

There is some ongoing work happening on the stunnel package, this is likely already fixed in the development version that hasn't been pushed yet.

#2 Updated by Steve Beaver 9 months ago

  • Status changed from New to Feedback

This was corrected in stunnel 5.37

#3 Updated by Steve Wheeler 6 months ago

  • Status changed from Feedback to Resolved

No php errors in current package: pfSense-pkg-stunnel-5.47_1

Also available in: Atom PDF