Project

General

Profile

Actions

Feature #9078

closed

Investigate adding knobs for explicit-exit-notify in OpenVPN

Added by Chris Linstruth about 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
10/29/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:

Description

explicit-exit-notify looks like it can greatly speed up recovery time on OpenVPN process restarts and potentially HA server installations.

From https://community.openvpn.net/openvpn/wiki/Openvpn24ManPage

       --explicit-exit-notify [n]
              In UDP client mode or point-to-point mode, send server/peer an
              exit notification if tunnel is restarted or OpenVPN process is
              exited.  In client mode, on exit/restart, this option will tell
              the server to immediately close its client instance object
              rather than waiting for a timeout.  The n parameter (default=1)
              controls the maximum number of attempts that the client will try
              to resend the exit notification message.

              In UDP server mode, send RESTART control channel command to
              connected clients. The n parameter (default=1) controls client
              behavior. With n = 1 client will attempt to reconnect to the
              same server, with n = 2 client will advance to the next server.

              OpenVPN will not send any exit notifications unless this option
              is enabled.
Actions #1

Updated by Jim Pingle about 2 years ago

  • Assignee set to Jim Pingle
  • Target version set to 2.5.0
Actions #2

Updated by Jim Pingle about 2 years ago

  • Description updated (diff)
Actions #3

Updated by Jim Pingle about 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Jim Pingle almost 2 years ago

  • Target version changed from 2.5.0 to 2.4.5

Applies cleanly to 2.4.5, so I picked it back.

Actions #5

Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Resolved

Options are present and appear to work as intended.
2.4.5.a.20191218.2354

Actions

Also available in: Atom PDF