Project

General

Profile

Bug #9086

Local Database authentication is failing in other languages

Added by Renato Botelho over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Authentication
Target version:
Start date:
11/01/2018
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.4.4
Affected Architecture:

Description

A user reported this problem on a pt_BR group. After changing language it stopped working. I noted it is storing translated string into config.xml

History

#1 Updated by Renato Botelho over 2 years ago

  • Status changed from New to Feedback

#2 Updated by Vladimir Lind over 2 years ago

On 3100 2.4.5-DEVELOPMENT (arm) сделан Mon Nov 05 15:36:37 EST 2018 changed language to Russian, then logged out and logged in again successfully with default local admin account.

#3 Updated by Renato Botelho over 2 years ago

  • Status changed from Feedback to Resolved

#4 Updated by Steve Wheeler over 2 years ago

  • Status changed from Resolved to Feedback

I believe this only affects captive portal logins. We were not able to replicate it any other way. Testing that now....

#5 Updated by Steve Wheeler over 2 years ago

  • Status changed from Feedback to Resolved

Replicated in 2.4.4.
Configured CP for auth against local database and added a test user. Changed system language to German. Edit CP, no auth server is now set, set local-database again. Users can no longer login.

Tested:
2.4.5-DEVELOPMENT (amd64)
built on Thu Nov 15 22:32:47 EST 2018
"Local-Database" is no longer translated to is valid as an auth selection. Users are able to login.

Also available in: Atom PDF