Project

General

Profile

Bug #9116

IPsec VTI routes not applied at boot time when gateway monitoring is disabled

Added by Jim Pingle over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
IPsec
Target version:
Start date:
11/13/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.4.4
Affected Architecture:
All

Description

With gateway monitoring enabled, an interface event kicks off a restart of other scripts which apply the routing and then the route is present in the table.

With gateway monitoring disabled, the route is not present in the table at all.

Looking at the code, the IPsec interface configure explicitly does not set routes at boot time, which is likely the cause. Removing the check lets it work and appears to have no negative side effects.

Associated revisions

Revision ed104a18 (diff)
Added by Jim Pingle over 2 years ago

Always configure VTI routes when setting up the interface. Fixes #9116

Revision 9887b24e (diff)
Added by Jim Pingle over 2 years ago

Always configure VTI routes when setting up the interface. Fixes #9116

(cherry picked from commit ed104a182a95f0ce4e6df76a8c3f0698ff7ce092)

History

#1 Updated by Jim Pingle over 2 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

#2 Updated by Yordan Georgiev over 2 years ago

Jim Pingle wrote:

Applied in changeset ed104a182a95f0ce4e6df76a8c3f0698ff7ce092.

Fix works fine! Tnx!

#3 Updated by Jim Pingle over 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF