Project

General

Profile

Bug #912

PPTP/PPPoE/L2TP VPN logs missing

Added by Chris Buechler almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
PPTP
Target version:
Start date:
09/21/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

The PPP log migration I believe targeted the PPTP logs as well. Regressions:

1) It's not logging PPTP at all that I can find at least.
2) Those need to be returned to their own log, as they'll otherwise frequently get buried in a flood of PPPoE or PPP logs.
3) the PPTP log tab needs to come back, as it wasn't a simple text log display, and is effectively the status screen for PPTP as much as one exists.

Associated revisions

Revision 14905d9f (diff)
Added by Jim Pingle almost 9 years ago

Show login/logout events for pptp, pppoe server, and l2tp. Could use some work to simplify. Ticket #912.

Revision 874e5f2c (diff)
Added by Jim Pingle almost 9 years ago

Fix VPN log page to use the updated log format (again). Ticket #912.

Revision b2b61308 (diff)
Added by Jim Pingle almost 9 years ago

Switch from buttons to tabs, add a mode to view raw mpd logs for each vpn type, and some general cleanup. Fixes #912

Revision a6607b5f (diff)
Added by Jim Pingle almost 9 years ago

More VPN log fixes, for consistency. Ticket #912

History

#1 Updated by Marcus Brown almost 9 years ago

First, you're referring to PPTP server right?
I'm pretty sure they're supposed to be under the "VPN" tab of the System Log screen. Then there's a button that lets you select which log you want.

#2 Updated by Tony Graziano almost 9 years ago

Yes, exactly, that is empty when you click that button.

Last 50 PPTP VPN log entries
Time Action User IP address

<empty>

#3 Updated by Jim Pingle almost 9 years ago

  • Subject changed from PPTP logs missing to PPTP/PPPoE/L2TP VPN logs missing

I tracked this down a bit more somewhat by accident.

It seems that the GUI log viewer is looking at /var/log/(vpn type).log, but that is where mpd is writing the logs with all of its information. In the link up and link down scripts, it writes the login and logout events to /var/log/vpn.log - but this log is missing the type of service being logged into or out of.

The GUI will not see the login/logout events because the logs it's looking at are full of mpd info and not what it's expecting to parse, and it can't differentiate the data in the other file even if that were changed.

The way forward would seem to be that the linkup/linkdown scripts for pptp/l2pt/pppoe need adjusted to include their service type in the vpn log, and then the GUI page needs adjusted to (a) use vpn.log to show login/logout info, and (b) have some way to display the raw mpd log for each service.

#4 Updated by Jim Pingle almost 9 years ago

The logs for login/logout events should be back now in a bit more efficient way. Separate linkup and linkdown scripts are no longer needed, I consolidated all of them into a single linkup and linkdown script, and actions can key off of the interface name.

#5 Updated by Jim Pingle almost 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#6 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF