Project

General

Profile

Bug #9180

Unable to sign a CSR using sha512

Added by Jim Pingle 7 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Certificates
Target version:
Start date:
12/07/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

When signing a CSR, selecting SHA512 yields an input error claiming the selected algorithm is invalid.

I can reproduce the issue, it appears to be hitting a test meant for a different mode (not 'sign') and since that incorrect test is firing it is looking at the wrong field.

Associated revisions

Revision ed76624b (diff)
Added by Jim Pingle 7 months ago

Rework cert keylen/digest validation. Fixes #9180

Revision f8ce2bd4 (diff)
Added by Jim Pingle 7 months ago

Rework cert keylen/digest validation. Fixes #9180

(cherry picked from commit ed76624bf01c0d1718d427919145bf4e5f949264)

History

#1 Updated by Jim Pingle 7 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#2 Updated by Jim Pingle 7 months ago

  • Target version changed from 48 to 2.4.4-p2

#3 Updated by Steve Wheeler 6 months ago

  • Status changed from Feedback to Resolved

Replicated in 2.4.4p1:

The following input errors were detected:

    Please select a valid Digest Algorithm.

Confirmed no error in:
2.4.5-DEVELOPMENT (amd64)
built on Fri Dec 21 17:32:53 EST 2018
FreeBSD 11.2-RELEASE-p6

Also available in: Atom PDF