Project

General

Profile

Bug #9210

dnsmadeeasy not working on PPPoE interface

Added by Corey Boyle 12 months ago. Updated 4 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
-
Start date:
12/18/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4_1
Affected Architecture:

Description

    <opt5>
        <descr><![CDATA[DSL]]></descr>
        <if>pppoe0</if>
        <enable></enable>
        <spoofmac></spoofmac>
        <ipaddr>pppoe</ipaddr>
        <blockpriv></blockpriv>
        <blockbogons></blockbogons>
    </opt5>
    <ppps>
        <ppp>
            <ptpid>0</ptpid>
            <type>pppoe</type>
            <if>pppoe0</if>
            <ports>lagg0.1003</ports>
            <username>xxx</username>
            <password>xxx</password>
            <provider></provider>
        </ppp>
    </ppps>
    <dyndns>
        <type>dnsmadeeasy</type>
        <username>xxx</username>
        <password>xxx</password>
        <host>xxx</host>
        <domainname></domainname>
        <mx></mx>
        <verboselog></verboselog>
        <enable></enable>
        <interface>opt5</interface>
        <zoneid></zoneid>
        <ttl></ttl>
        <updateurl></updateurl>
        <resultmatch></resultmatch>
        <requestif>opt5</requestif>
        <descr><![CDATA[lewiston-dsl.xxx.]]></descr>
        <id>0</id>
    </dyndns>

Dec 18 16:21:12     php-fpm     21650     /services_dyndns_edit.php: Dynamic DNS: updatedns() starting
Dec 18 16:21:12     php-fpm     21650     /services_dyndns_edit.php: Dynamic DNS dnsmadeeasy (xxx): xxx.73.79.67 extracted from local system.
Dec 18 16:21:12     php-fpm     21650     /services_dyndns_edit.php: Dynamic DNS (xxx): running get_failover_interface for opt5. found pppoe0
Dec 18 16:21:13     php-fpm     21650     /services_dyndns_edit.php: Dynamic DNS dnsmadeeasy (xxx): xxx.73.79.67 extracted from local system.
Dec 18 16:21:13     php-fpm     21650     /services_dyndns_edit.php: Dynamic Dns (xxx): Current WAN IP: xxx.73.79.67 Cached IP: 0.0.0.0
Dec 18 16:21:13     php-fpm     21650     /services_dyndns_edit.php: DynDns (xxx): Dynamic Dns: cacheIP != wan_ip. Updating. Cached IP: 0.0.0.0 WAN IP: xxx.73.79.67
Dec 18 16:21:13     php-fpm     21650     /services_dyndns_edit.php: Dynamic DNS dnsmadeeasy (xxx): _update() starting.
Dec 18 16:22:28     php-fpm     21650     /services_dyndns_edit.php: Dynamic DNS dnsmadeeasy (xxx): _checkStatus() starting.
Dec 18 16:22:28     php-fpm     21650     /services_dyndns_edit.php: Curl error occurred: Failed to connect to cp.dnsmadeeasy.com port 443: Operation timed out 

If I switch the interface to another WAN, it works perfectly, but once I switch it back to the DSL interface, I get the same error message.

History

#1 Updated by Jim Pingle 4 months ago

  • Status changed from New to Not a Bug

A connection timeout sounds more like a routing issue than anything specific to PPPoE or DynDNS. If you can still reproduce this on a 2.5.0 snapshot, post on the forum for help tracking down the real underlying issue here.

Also available in: Atom PDF