Project

General

Profile

Bug #9248

Dynamic dns updates on azure ipv6 service is not working properly

Added by Holger Stoecker about 1 year ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Low
Category:
Dynamic DNS
Target version:
Start date:
01/02/2019
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

When using the azure v6 dynamics dns update there is an issue that the dns entry is showing up at the azure dns management website but the value of the dns entry is null.
The problem is that the json request body contains a wrong property. It has to be "AAAARecords" instead of "AaaaRecords" in the file /src/etc/inc/dyndns.class line 1103.
The issue is already fixed with the following pull request on github:
https://github.com/imp3r4t0r/pfsense/tree/patch-1

History

#1 Updated by Jim Pingle 10 months ago

  • Project changed from pfSense Packages to pfSense
  • Category set to Dynamic DNS
  • Target version set to 2.5.0
  • Affected Version set to All
  • Affected Architecture All added
  • Affected Architecture deleted ()

#2 Updated by Renato Botelho 9 months ago

  • Status changed from New to Feedback
  • Assignee set to Renato Botelho
  • % Done changed from 0 to 100

PR has been merged. Thanks!

#3 Updated by Jim Pingle 3 months ago

  • Target version changed from 2.5.0 to 2.4.5

#4 Updated by Jim Pingle about 2 months ago

  • Status changed from Feedback to Resolved

Not a service we can test internally, and no response from OP or other consumers of the service in question, so closing. Can revisit in a new issue if there are problems with the change.

Also available in: Atom PDF