Project

General

Profile

Actions

Bug #9276

closed

DNS troubleshooting tool incorrectly reporting "ai." as an invalid hostname

Added by Steve Malloy almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Very Low
Assignee:
Category:
Web Interface
Target version:
Start date:
01/17/2019
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:
All

Description

To reproduce:

Navigate to Diagnostics=>DNS Lookup (found at /diag_dns.php). Enter any TLD that should work as a single-label domain, "ai." for example. Include the terminating dot that indicates you mean an FQDN. This is a valid hostname. You will get a response saying otherwise.

I have tested this on 2.4.4-RELEASE-p1 and -p2. It is not an issue with ubound. Using dig at a command line does show the hostname (with terminating dot) to resolve just fine. The problem is at the diagnostic feature web page.


Files

Actions #1

Updated by Jim Pingle almost 3 years ago

  • Assignee set to Jim Pingle
  • Target version set to 48
  • Affected Version set to All

Looks like it's easily fixed by having the validation check ignore a trailing dot on the hostname, but including it in the query.

Actions #2

Updated by Jim Pingle almost 3 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #3

Updated by Vladimir Lind almost 3 years ago

On 2.4.5-DEVELOPMENT (arm)
built on Fri Jan 25 05:46:46 EST 2019

Entered "ai.: in Diagnostics=>DNS Lookup and got response -> 209.59.119.34 A

Looks good.

Actions #4

Updated by Jim Pingle almost 3 years ago

  • Status changed from Feedback to Resolved
Actions #5

Updated by Jim Pingle over 2 years ago

  • Target version changed from 48 to 2.5.0
Actions #6

Updated by Jim Pingle over 2 years ago

  • Target version changed from 2.5.0 to 2.4.4-p3
Actions #7

Updated by Jim Pingle over 2 years ago

  • Status changed from Resolved to Feedback
Actions #8

Updated by Chris Linstruth over 2 years ago

2.4.4-p3

Diagnostics > DNS Lookup accepts ai. as a hostname and returns valid results. Ran a couple other queries - all fine.

Actions #9

Updated by Jim Pingle over 2 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF