Project

General

Profile

Todo #9360

Switch to Python 3.x

Added by Jim Pingle over 1 year ago. Updated 10 days ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
03/01/2019
Due date:
% Done:

100%

Estimated time:

Description

Python 2.7.x is not long for this world, going EOL on Jan 1, 2020

We need to ensure the base packages and other packages that require python 2.7 can be moved to python 3.6 or later.

pfSense itself does not have any direct dependencies, but some base packages do such as Unbound, bind-tools, rrdtool (via glib). Additionally, pfSense packages like FreeRADIUS, cellular, and Suricata show dependencies on python 2.7.

Renato has already started this work, and most items build successfully with python 3.6, though more testing is warranted.

History

#1 Updated by Renato Botelho over 1 year ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100

Already done. Python 2.x is not required anymore

#2 Updated by Renato Botelho 10 days ago

  • Status changed from Feedback to Resolved

1 year is enough time for testing :)

Also available in: Atom PDF