Project

General

Profile

Bug #9401

26 to 31 character VPN interface names cause gateway names to exceed 31 character limit

Added by Richard Yao over 1 year ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Category:
Gateways
Target version:
Start date:
03/15/2019
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

If you make an OpenVPN interface name with 26 to 31 characters (in my case, I made them with exactly 26 and 31 characters), _VPNV4 and _VPNV6 are appended to them when making the gateways under System / Routing / Gateways. Trying to add a monitor IP is impossible because the 31 character limit is exceeded and attempting to change the gateway name to honor the limit is not allowed. Working around this requires picking shorter interface names.

I am running 2.4.4_2. I have not tried newer versions to see if this has changed.

Associated revisions

Revision cec267cb (diff)
Added by Viktor Gurov 8 months ago

Special interfaces description length validation. Issue #9401

History

#1 Updated by Jim Pingle about 1 year ago

  • Subject changed from 26 to 31 character OpenVPN interface names cause gateway names to exceed 31 character limit to 26 to 31 character VPN interface names cause gateway names to exceed 31 character limit
  • Category set to Gateways
  • Affected Version changed from 2.4.4_2 to All

#2 Updated by Viktor Gurov 8 months ago

This is caused by special suffixes added to some special interfaces:
_VPNV4 and _VPNV6 for OpenVPN and VTI interfaces
_TUNNELV4 and _TUNNELV6 for GIF and GRE interfaces

Check description length:
https://github.com/pfsense/pfsense/pull/4205

#3 Updated by Jim Pingle 8 months ago

  • Status changed from New to Pull Request Review
  • Target version set to 2.5.0

#4 Updated by Renato Botelho 8 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • % Done changed from 0 to 100

PR has been merged. Thanks!

#5 Updated by Viktor Gurov 8 months ago

  • Status changed from Feedback to Resolved

works as expected on 2.5.0.a.20200312.1334

Also available in: Atom PDF