Project

General

Profile

Bug #9474

no default gateway after changing the wan interface ipv4 configuration type from dhcp to fixed ip

Added by david stievenard 8 months ago. Updated 4 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Routing
Target version:
-
Start date:
04/15/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4_2
Affected Architecture:

Description

what started the problem

- ISP unexpectedly changed it's router configuration from dhcp to static ip but all IP are unchanged
- so I had to configure the wan interface from dhcp to static ip

Symtoms

- firewall can access to internet, ping, dns resolution ok
- connecting from internet to the firewall works
- local users can use the firewall, local dns
- users can't access to internet (destination unreacheable)
- [status / ipsec / oversview] just shows "collecting informations"
- ipsec tunnel doesn't go up
- rebooting didn't fix the problem

Fixing the problem

- in [system/routing }
- I have 2 gateways :
- one for the ISP
- one for "pfSense-initiated traffic for IPsec" (the classic trick to send some dns resolution traffic in the ipsec tunnel to HQ)
- default ipv4 gateway is configured as "automatic"
- none of the gateways has the "(default)" tag

- I changed the default gateway ipv4 to isp -> problem solved
- Tried to put it back in automatic -> no effects, ISP gateway is still the default one

conclusion
- seems changing the wan interface configuration + automatic gateway created the problem

Version pfsense 2.4.4_2

History

#1 Updated by Jim Pingle 4 months ago

  • Status changed from New to Not a Bug

Sounds like a config issue but there isn't enough detail to say for certain.

For assistance in solving problems, please post on the Netgate Forum or the pfSense Subreddit .

See Reporting Issues with pfSense Software for more information.

Also available in: Atom PDF