Project

General

Profile

Todo #9501

turn off form autocompletion on OpenVPN client config page (maybe the whole web interface)

Added by Corey Boyle 7 months ago. Updated 7 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
OpenVPN
Target version:
-
Start date:
05/06/2019
Due date:
% Done:

0%

Estimated time:

Description

Some of the fields (usually the proxy info) will get autofilled by the browser with random data.

History

#1 Updated by Jim Pingle 7 months ago

  • Status changed from New to Not a Bug
  • Target version deleted (2.5.0)

Browsers no longer respect autocomplete settings in HTML. We can set the tags, but browsers and password manager plugins ignore them.

#2 Updated by Corey Boyle 7 months ago

Sorry, should have done my homework first.

https://stackoverflow.com/questions/15738259/disabling-chrome-autofill

Would renaming the "password" fields on that page help at all?

#3 Updated by Jim Pingle 7 months ago

Not effectively, because they also key off the form field labels, and then it becomes a never-ending whack-a-mole of hiding the field names and the browsers tracking them down again. There are some javascript tricks I've seen to throw them off but it requires things like randomizing field names which makes the front and backend code a lot more complicated.

In the end there isn't much we can do about client behavior when the client has decided it knows better than the page.

Also available in: Atom PDF