Project

General

Profile

Actions

Bug #9505

closed

Multiple Dynamic DNS update notifications for the same interface, with the same text

Added by robi robi about 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
05/07/2019
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

We have multiple Dynamic DNSes set up for the same interface. Whenever an update happens, we get as many e-mails as many entries are set up for the sane interface, all with the following same text:

Notifications in this message: 1
================================

14:03:46 DynDNS updated IP Address on WAN2 (igb0) to 1.2.3.4

It would be better if there would be one single notification e-mail message containing all the entries, not several e-mails all in a row.

Actions #1

Updated by Jim Pingle about 2 years ago

  • Status changed from New to Duplicate

Duplicate of #9504

Actions #2

Updated by robi robi about 2 years ago

I wouldn't say this is a duplicate, because this bug is about sending too many messages after each other about (almost) the same information (concatenate messages) while the other bug is about the fact that the notification text is not informative enough.

Two different things.

Actions #3

Updated by Jim Pingle about 2 years ago

See my comments on the other message, then. There is already code to handle that. Either this is a duplicate or it's not legitimate, take your pick. The messages are already grouped when possible.

Actions #4

Updated by robi robi about 2 years ago

Unfortunately grouping doesn't work correctly then. All events happen withing 20 seconds or so, and we get separate messages for various events.
I think grouping should handle a bigger timeframe (say 1 minute) and should consider events coming from the same source.

Actions #5

Updated by Jim Pingle about 2 years ago

It works fine, I get multiple grouped messages every day for various things when testing. The window is 10s. If you want to discuss it more, open a forum thread. All of these should be forum threads first, not issues. Not until they have been vetted.

Actions #6

Updated by robi robi about 2 years ago

10 seconds? Aaaahhh....

OK

Actions

Also available in: Atom PDF