Project

General

Profile

Bug #9522

Diagnostics > System Activity shows only the header

Added by Steve Wheeler about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
05/12/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.x
Affected Architecture:

Description

In current 2.5 snapshots the 'top' output in Diagnostics > System Activity seems truncated.

I see only:

last pid: 33054;  load averages:  0.02,  0.07,  0.08  up 0+01:06:12    12:36:32
120 threads:   3 running, 104 sleeping, 13 waiting
CPU:  0.9% user,  0.1% nice, 14.8% system,  0.0% interrupt, 84.1% idle
Mem: 46M Active, 195M Inact, 552M Wired, 389M Buf, 3107M Free
Swap: 

It also seems to be showing different values to running the command at the CLI at the same time:

[2.5.0-DEVELOPMENT][root@fw321.stevew.lan]/root: top -aSH
last pid: 31065;  load averages:  0.04,  0.07,  0.08                                                                             up 0+01:07:24  12:37:44
122 threads:   3 running, 106 sleeping, 13 waiting
CPU:  0.0% user,  0.0% nice,  0.0% system,  0.0% interrupt,  100% idle
Mem: 50M Active, 196M Inact, 552M Wired, 389M Buf, 3102M Free
Swap: 

  PID USERNAME    PRI NICE   SIZE    RES STATE    C   TIME    WCPU COMMAND
   11 root        155 ki31      0    32K CPU1     1  56:59 100.00% [idle{idle: cpu1}]
   11 root        155 ki31      0    32K RUN      0  56:47  99.65% [idle{idle: cpu0}]
26126 root         20    0    13M  3840K CPU0     0   0:00   0.18% top -aSH
    9 root        -16    -      0    16K -        0   0:02   0.04% [rand_harvestq]
   12 root        -60    -      0   208K WAIT     0   0:02   0.04% [intr{swi4: clock (0)}]

Tested against: pfSense-2.5.0.a.20190511.1744

Also available in: Atom PDF