Project

General

Profile

Bug #9528

FRR OSPF state stuck in Extart / Exchange because of MTU following pfSense restart

Added by Steven Perreau about 1 month ago. Updated 19 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
05/17/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4_2
Affected Architecture:
All

Description

1. Build FRR with OSPF, build the VTi interfaces, etc. Start OSPF and it will work. OSFP will link up neighbor state "Full/DROther"
2. Reboot pFsense and OSPF will not move past neighbor Exstart.
3. Manually set the MTU to 1400 inside the "Interfaces / if name (ipsecxxxxx)" - OSPF works and survives a reboot and moves immediately to neighbor state "Full/DROther"

It seems the MTU on the VTi interface is somehow altering after a reboot.

Also, I couldn't get any other MTU to work, 1420, 1432, 1436, only 1400 worked.

History

#1 Updated by Jim Pingle 19 days ago

  • Status changed from New to Duplicate

This is fixed on 2.5.0, see #9111

The problem is not with FRR, but with IPsec VTI MTU handling.

Also available in: Atom PDF