Project

General

Profile

Bug #9557

FRR Upgrades

Added by Jim Pingle 5 months ago. Updated 27 days ago.

Status:
Resolved
Priority:
Low
Category:
FRR
Target version:
-
Start date:
05/28/2019
Due date:
% Done:

100%

Estimated time:
Affected Version:
Affected Architecture:
All

Description

FRR 6.0.x seems to be OK on pfSense 2.5.0, so we need to play a bit of musical FRR upgrades:

  • Copy FRR 6.0.x back to pfSense 2.4.4-p3
  • Copy the current pfSense FRR package back to pfSense 2.4.4-p3 since it contains necessary changes for FRR 6.0.x
  • Move pfSense 2.5.0 snapshots to FRR 7. This is in the ports tree under net/frr7 but it is not in the quarterly branch used by pfSense 2.5.0, so it needs some work to import

If there is a blocking issue in the pfSense 2.4.4 ports tree which makes the upgrade to 6 not viable, that part can be skipped and we can still move pfSense 2.5.0 up to FRR 7.

History

#1 Updated by Renato Botelho 5 months ago

  • Status changed from New to Feedback
  • Target version set to 2.5.0
  • % Done changed from 0 to 100

2.4.4 now uses FRR 6.x and 2.5.0 moved to 7.x

#2 Updated by Jim Pingle 5 months ago

pfSense 2.4.4 is using FRR 6 as expected. Still waiting on a new snapshot to check on pfSense 2.5.0/FRR 7

#3 Updated by Jim Pingle 5 months ago

  • Status changed from Feedback to Resolved

2.5.0 snaps have FRR 7 now and it appears to be running OK

#4 Updated by Jim Pingle 27 days ago

  • Target version deleted (2.5.0)

Also available in: Atom PDF