Project

General

Profile

Bug #9561

PPPoe 6RD broken in 2.5

Added by Ronald Schellberg 4 months ago. Updated about 1 month ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
05/28/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.0
Affected Architecture:

Description

Been using 2.5 for a while when I noticed that I had disabled ipv6 on 2.4 before upgrading. Tried enabling a Centurylink 6rd tunnel on 2.5 (2.5.0.a.20190520.1137) and found the test-ipc6.com tests were failing. Switched back to 2.4.4 to find the 6rd tunnel was functioning. Both were using the same configuration file.

In the working 2.4.4 log I find:


May 25 16:38:53 ppp [wan] IFACE: Up event
May 25 16:38:53 ppp [wan] IFACE: Rename interface ng0 to pppoe2
May 25 16:38:54 php-fpm 545 /rc.newwanip: rc.newwanip: Info: starting on pppoe2.
May 25 16:38:54 php-fpm 545 /rc.newwanip: rc.newwanip: on (IP address: 75.174.59.240) (interface: WAN[wan]) (real interface: pppoe2).
May 25 16:38:54 dhcpleases /etc/hosts changed size from original!
May 25 16:38:54 kernel stf0: changing name to 'wan_stf'
May 25 16:38:54 php-fpm 545 /rc.newwanip: rd6 lan with ipv6 address 2602:4b:ae3b:f000::1 based on wan ipv4 75.174.59.240
May 25 16:38:56 php-fpm 544 /interfaces.php: rd6 lan with ipv6 address 2602:4b:ae3b:f000::1 based on wan ipv4 75.174.59.240
May 25 16:38:56 kernel stf0: changing name to 'wan_stf'

The 2.5 Log contains:


May 26 08:05:42 ppp 8922 [wan] IFACE: Up event
May 26 08:05:42 ppp 8922 [wan] IFACE: Rename interface ng0 to pppoe2
May 26 14:05:42 php 378 rc.bootup: The command '/sbin/ifconfig wan_stf inet6 2602:4b:ae2a:a100::/24' returned exit code '1', the output was 'ifconfig: ioctl (SIOCAIFADDR): Invalid argument'
May 26 08:05:42 kernel stf0: changing name to 'wan_stf'

Two observations in the 2.5 log; one, the time stamp is off 6 hours in the rc.bootup entry (and others in the full log), and the "/sbin/ifconfig wan_stf" command is failing.

The working 2.4.4_p3 ifconfig results are:


em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC>
ether xx:xx:xx:xx:xx:xx
hwaddr xx:xx:xx:xx:xx:xx
inet 192.168.xxx.1 netmask 0xffffff00 broadcast 192.168.xxx.255
inet6 fe80::1:1%em0 prefixlen 64 scopeid 0x1
inet6 2602:xx:xxxx:xxxxx::1 prefixlen 64
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
alc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=c319a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC,VLAN_HWTSO,LINKSTATE>
ether xx:xx:xx:xx:xx:xx
hwaddr xx:xx:xx:xx:xx:xx
inet6 fe80::xxxx:xxxx:xxxx:xxxx%alc0 prefixlen 64 scopeid 0x2
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
enc0: flags=0<> metric 0 mtu 1536
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
groups: enc
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
groups: lo
pflog0: flags=100<PROMISC> metric 0 mtu 33160
groups: pflog
pfsync0: flags=0<> metric 0 mtu 1500
groups: pfsync
syncpeer: 224.0.0.240 maxupd: 128 defer: on
syncok: 1
pppoe2: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> metric 0 mtu 1492
inet xx.xxx.xxx.xxx --> xxx.xx.xx.xx netmask 0xffffffff
inet6 fe80::xxxx:xxxx:xxxx:xxxx%pppoe2 prefixlen 64 scopeid 0x7
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
ovpns1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1500
options=80000<LINKSTATE>
inet6 fe80::xxxx:xxxx:xxxx:xxxx%ovpns1 prefixlen 64 scopeid 0x8
inet 10.0.xxx.1 --> 10.0.xxx.2 netmask 0xffffff00
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
groups: tun openvpn
Opened by PID 1325
wan_stf: flags=4041<UP,RUNNING,LINK2> metric 0 mtu 1280
inet6 2602:xx:xxxx:xxxx:: prefixlen 24
nd6 options=1<PERFORMNUD>
v4net 65.129.137.112/32 -> tv4br 205.171.2.64
groups: stf

Results of the ifconfig on 2.5 are:


em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=81259b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,LRO,WOL_MAGIC,VLAN_HWFILTER>
ether xx:xx:xx:xx:xx:xx
inet 192.168.xxx.1 netmask 0xffffff00 broadcast 192.168.xxx.255
inet6 fe80::1:1%em0 prefixlen 64 scopeid 0x1
inet6 2602:xx:xxxx:xxxx::1 prefixlen 64
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
alc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=c319a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC,VLAN_HWTSO,LINKSTATE>
ether xx:xx:xx:xx:xx:xx
inet6 fe80::xxxx:xxxx:xxxx:xxxx%alc0 prefixlen 64 scopeid 0x2
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
enc0: flags=0<> metric 0 mtu 1536
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
groups: enc
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=680003<RXCSUM,TXCSUM,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
groups: lo
pflog0: flags=100<PROMISC> metric 0 mtu 33160
groups: pflog
pfsync0: flags=0<> metric 0 mtu 1500
groups: pfsync
syncpeer: 224.0.0.240 maxupd: 128 defer: on
syncok: 1
pppoe2: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> metric 0 mtu 1492
inet xxx.xxx.xxx.xxx --> xxx.xxx.xxx.xxx netmask 0xffffffff
inet6 fe80::xxxx:xxxx:xxxx:xxxx%pppoe2 prefixlen 64 scopeid 0x7
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
ovpns1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1500
options=80000<LINKSTATE>
inet6 fe80::xxxx:xxxx:xxxx:xxxx%ovpns1 prefixlen 64 scopeid 0x9
inet 10.0.xxx.1 --> 10.0.xxx.2 netmask 0xffffff00
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
groups: tun openvpn
Opened by PID 66485
wan_stf: flags=4000<LINK2> metric 0 mtu 1280
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
groups: stf

Happy to provide other diagnostics, let me know.

History

#1 Updated by Ronald Schellberg 2 months ago

Doesn't appear that "pfSense patch stf_6rd.diff", ticket 7272 (commit cb59ac304d30d5009537d7de0429792fb33d3db0 which was cherry picked from commit 9b4f61fbff06039b57566ba7332b763188d6d301) was applied to 2.5 branch.

#2 Updated by Ronald Schellberg about 2 months ago

Created a pull request to FreeBSD-src to apply the 6RD changes to 2.5

#3 Updated by Jim Pingle about 1 month ago

  • Category set to Interfaces
  • Status changed from New to Duplicate
  • Target version deleted (2.5.0)

Duplicate of #9649

Also available in: Atom PDF