Project

General

Profile

Bug #9649

IPv6 6RD Tunnel

Added by Aaron Unpublished about 1 year ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Interfaces
Target version:
Start date:
07/27/2019
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.5.x
Affected Architecture:

Description

IPv6 6rd doesn't work on any 2.5.X versions at the moment.

Have cable internet. Upgraded to the 2.5 and it broke my IPv6. Looked for open issues on it and can't find anything except for one with PPPoE, however, I don't use PPPoE.

So, I downloaded the latest snapshot and did a fresh install, same issue.

Ended up downgrading for now back to 2.4.3 until this is resolved.

History

#1 Updated by Ronald Schellberg about 1 year ago

Aaron Unpublished wrote:

IPv6 6rd doesn't work on any 2.5.X versions at the moment.

Have cable internet. Upgraded to the 2.5 and it broke my IPv6. Looked for open issues on it and can't find anything except for one with PPPoE, however, I don't use PPPoE.

So, I downloaded the latest snapshot and did a fresh install, same issue.

Ended up downgrading for now back to 2.4.3 until this is resolved.

I believe this is related to #9561 and likely a regression #7272, where the stf_6rd.diff patch and a few others were created and applied to 2.4.

These changes have not been applied to 2.5 yet.

I have forked the code with 5 commits ahead of the current branch. Happy to submit a Pull Request if that would help move things along.

#2 Updated by Aaron Unpublished about 1 year ago

Ronald Schellberg wrote:

Aaron Unpublished wrote:

IPv6 6rd doesn't work on any 2.5.X versions at the moment.

Have cable internet. Upgraded to the 2.5 and it broke my IPv6. Looked for open issues on it and can't find anything except for one with PPPoE, however, I don't use PPPoE.

So, I downloaded the latest snapshot and did a fresh install, same issue.

Ended up downgrading for now back to 2.4.3 until this is resolved.

I believe this is related to #9561 and likely a regression #7272, where the stf_6rd.diff patch and a few others were created and applied to 2.4.

These changes have not been applied to 2.5 yet.

I have forked the code with 5 commits ahead of the current branch. Happy to submit a Pull Request if that would help move things along.

I would really appreciate it! THANK YOU!

#3 Updated by Ronald Schellberg about 1 year ago

Created a pull request to FreeBSD-src to apply the 6RD changes to 2.5

#4 Updated by Jim Pingle about 1 year ago

  • Category set to Interfaces

#5 Updated by Ronald Schellberg about 1 year ago

Ronald Schellberg wrote:

Created a pull request to FreeBSD-src to apply the 6RD changes to 2.5

Updated the pull request to fix compile errors in 2.5 and tested with current snap.

Wan_stf interface displays an appropriate ipv6 address now in the dashboard, ifconfig doesn't report errors and test-ipv6 score is 10/10.

The pull request has some debugging code from 2.4 still in it, should it be left in or removed?

#6 Updated by Renato Botelho about 1 year ago

  • Status changed from New to Pull Request Review
  • Assignee set to Luiz Souza

#7 Updated by Ronald Schellberg 8 months ago

Any concerns or progress with the Pull Request? I have applied slight variations to 2.5, RELENG 12.1 and Stable-12. That PR is the main reason I'm having to create parallel builds.

#8 Updated by Ronald Schellberg 6 months ago

Ronald Schellberg wrote:

Any concerns or progress with the Pull Request? I have applied slight variations to 2.5, RELENG 12.1 and Stable-12. That PR is the main reason I'm having to create parallel builds.

I would be more than happy to resubmit the PR based on devel-12, if it would get incorporated.

#9 Updated by Ronald Schellberg 4 months ago

PR #25 got closed today without being applied. Looks like it may be a while for this Issue to be resolved.

#10 Updated by Luiz Souza 4 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100

PR committed.

Please test with the next snapshot.

#11 Updated by Ronald Schellberg 4 months ago

Thanks for committing the PR. I can confirm that the next snapshot fixes the issue.

#12 Updated by Jim Pingle 4 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF