Project

General

Profile

Bug #9655

NUT missing from netgate UI

Added by Richard Davis over 1 year ago. Updated over 1 year ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Nut
Target version:
-
Start date:
07/28/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4-p3
Affected Architecture:

Description

After installing the nut package from the package manager on a new netgate system with the built-in theme, the NUT service is not available from the Services drop down menu. The service is listed in the Service Status widget on the main Dashboard.

Attempts to access the UI directly (reverse engineering from an older non-netgate pfsense system) using /status_nut.php result in a 404.

I would like to 1) report this a bug, 2) find a workaround to access the NUT status / configuration directly as a workaround.

NUT: nut 2.7.4_7
System: Netgate SG-5100
Version: 2.4.4-RELEASE-p3 (amd64), FreeBSD 11.2-RELEASE-p10

nut.png (186 KB) nut.png Richard Davis, 07/28/2019 03:19 PM

History

#1 Updated by Jim Pingle over 1 year ago

  • Status changed from New to Not a Bug

You just need to reinstall the package. Somehow it isn't fully installed, and there isn't enough information here to speculate as to why.

#2 Updated by Richard Davis over 1 year ago

I've tried uninstalling, then installing, and "reinstalling" without success:

Reinstallation log:

>>> Upgrading pfSense-pkg-nut... 
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be REINSTALLED:
    pfSense-pkg-nut-2.7.4_7 [pfSense]

Number of packages to be reinstalled: 1
[1/1] Reinstalling pfSense-pkg-nut-2.7.4_7...
[1/1] Extracting pfSense-pkg-nut-2.7.4_7: .......... done
Removing nut components...
Menu items... done.
Services... done.
Loading package instructions...
Saving updated package information...
overwrite!
Loading package configuration... done.
Configuring package components...
Loading package instructions...
Custom commands...
Executing custom_php_install_command()...done.
Executing custom_php_resync_config_command()...done.
Menu items... done.
Services... done.
Writing configuration... done.
>>> Cleaning up cache... done.
Success

system.log:

Jul 29 23:43:27 router0 php: /etc/rc.packages: Beginning package installation for nut .
Jul 29 23:43:27 router0 check_reload_status: Syncing firewall
Jul 29 23:43:27 router0 php: /etc/rc.packages: Successfully installed package: nut.
Jul 29 23:43:27 router0 pkg-static: pfSense-pkg-nut reinstalled: 2.7.4_7 -> 2.7.4_7
Jul 29 23:43:30 router0 check_reload_status: Reloading filter
Jul 29 23:43:30 router0 check_reload_status: Starting packages
Jul 29 23:43:31 router0 php-fpm: /rc.start_packages: Restarting/Starting all packages.

I can provide additional details, but I'm not sure what would be useful ...

#3 Updated by Flole Systems over 1 year ago

Its in your Screenshot as "UPS".

#4 Updated by Richard Davis over 1 year ago

Wow ... yes it is; thank you! ;)

Also available in: Atom PDF