Project

General

Profile

Bug #9669

dhcrelay stops working after certain time

Added by Luki TJ 10 months ago. Updated 9 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
DHCP Relay
Target version:
-
Start date:
08/05/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4-p3
Affected Architecture:
amd64

Description

dhcrelay service stops working after a few days runtime of the process.
I have one host connected to igb5.8 (opt1) which gets restarted pretty rare. If the dhcrelay service is up for more then about 48hours, dhcp discover messages get relayed to the dhcp server, the dhcp Server sends dhcp offers back, but theses offers never arrive at the client. The client keeps sending dhcp discover messages. If I do a simple restart of the dhcrelay service, the offers gets immediately to the client and the address assignment process finishes by a dhcp request- and acknowledge message. See attached log file from dhcp server.
I did another restart of the Server on 3rd August, about 24 hours after dhcrelay was started and everything worked finde. Today I had to restart the Service again.

my config:


        <dhcrelay>
                <enable></enable>
                <interface>opt1</interface>
                <server>172.16.xx.3,172.16.xx.4</server>
        </dhcrelay>

proccess output:

/usr/local/sbin/dhcrelay -i igb5.8 -i igb0 172.16.xx.3 172.16.xx.4

pfsense dhcp log:

Aug 5 12:37:35     dhcrelay         Sending on Socket/fallback
Aug 5 12:37:35     dhcrelay         Sending on BPF/igb5.8/0c:c4:<mac-igb5.8>
Aug 5 12:37:35     dhcrelay         Listening on BPF/igb5.8/0c:c4:<mac-igb5.8>
Aug 5 12:37:35     dhcrelay         Sending on BPF/igb0/0c:c4:<mac-igb0>
Aug 5 12:37:35     dhcrelay         Listening on BPF/igb0/0c:c4:<mac-igb0>
Aug 5 12:37:35     dhcrelay         For info, please visit https://www.isc.org/software/dhcp/
Aug 5 12:37:35     dhcrelay         All rights reserved.
Aug 5 12:37:35     dhcrelay         Copyright 2004-2018 Internet Systems Consortium.
Aug 5 12:37:35     dhcrelay         Internet Systems Consortium DHCP Relay Agent 4.3.6-P1
Aug 2 13:34:01     dhcrelay         Sending on Socket/fallback
Aug 2 13:34:01     dhcrelay         Sending on BPF/igb5.8/0c:c4:<mac-igb5.8>
Aug 2 13:34:01     dhcrelay         Listening on BPF/igb5.8/0c:c4:<mac-igb5.8>
Aug 2 13:34:01     dhcrelay         Sending on BPF/igb0/0c:c4:<mac-igb0>
Aug 2 13:34:01     dhcrelay         Listening on BPF/igb0/0c:c4:<mac-igb0>
Aug 2 13:34:01     dhcrelay         For info, please visit https://www.isc.org/software/dhcp/
Aug 2 13:34:01     dhcrelay         All rights reserved.
Aug 2 13:34:01     dhcrelay         Copyright 2004-2018 Internet Systems Consortium.
Aug 2 13:34:01     dhcrelay         Internet Systems Consortium DHCP Relay Agent 4.3.6-P1
dhcpd.log (14.2 KB) dhcpd.log dhcpd log Luki TJ, 08/05/2019 06:05 AM

History

#1 Updated by Luki TJ 10 months ago

#2 Updated by Jim Pingle 10 months ago

  • Status changed from New to Feedback

Can you test this, at least temporarily, on a 2.5.0 snapshot? Changes were made for #9466 which might affect this behavior.

There is a patch on that ticket which would also apply to 2.4.4-p3, but it would be best to try it on 2.5.0 to know for certain.

#3 Updated by Luki TJ 10 months ago

Thank you for the quick response.

I can try out the Patch, but the issue is to minor to switch to a development release - sorry. If it helps, I can do some tests in a virtualized lab environment.

#9466 has multiple revisions associated.

Revision f427d68d

Revision ef0045d8

Can you tell me please which one of these applies to 2.4.4-p3? Code is pretty identical, as far as I see, but the line numbers are different.

#4 Updated by Jim Pingle 10 months ago

f427d68dbca5ed9941b3bc01be1c4d81417c134f is the one for RELENG_2_4_4

#5 Updated by Luki TJ 10 months ago

Thanks, I'll try it out and report back in a few of days.

#6 Updated by Luki TJ 10 months ago

After more than 80 hours of service uptime for dhcrelay, I've restarted the Server and the address assignment process worked without any problems.

Aug 6 12:14:42     dhcrelay         Sending on Socket/fallback
Aug 6 12:14:42     dhcrelay         Sending on BPF/igb5.8/0c:c4:7a:<igb5.8-mac>
Aug 6 12:14:42     dhcrelay         Listening on BPF/igb5.8/0c:c4:7a:<igb5.8-mac>
Aug 6 12:14:42     dhcrelay         Sending on BPF/igb0/0c:c4:7a:<igb0-mac>
Aug 6 12:14:42     dhcrelay         Listening on BPF/igb0/0c:c4:7a:<igb0-mac>
Aug 6 12:14:42     dhcrelay         For info, please visit https://www.isc.org/software/dhcp/
Aug 6 12:14:42     dhcrelay         All rights reserved.
Aug 6 12:14:42     dhcrelay         Copyright 2004-2018 Internet Systems Consortium.
Aug 6 12:14:42     dhcrelay         Internet Systems Consortium DHCP Relay Agent 4.3.6-P1

Looks good so far.

#7 Updated by Jim Pingle 10 months ago

  • Status changed from Feedback to Duplicate

That's great! I think it's fairly safe to say that this can be closed out as a duplicate of #9466 (different symptoms of the same problem)

But if you do happen to notice the old behavior still occurs, this issue can be reopened.

Thanks for testing!

#8 Updated by Luki TJ 9 months ago

Just rebooted the Server after ~15 Days uptime without any issues. I would say the fix is fine for that matter. Case may be closed.

Also available in: Atom PDF