Project

General

Profile

Bug #9723

DHCPv6 server for several interfaces isn't working on all interfaces

Added by Pim Pish 9 months ago. Updated 6 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
DHCP (IPv6)
Target version:
-
Start date:
09/04/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.4
Affected Architecture:

Description

Hi,

I have a virtualized pfSense 2.4.4 p3 running with several downstream interfaces.
On some interfaces DHCPv6 server is working as expected. On one interface the DHCPv6 server simply does not answer (see screenshot).

When I attach my DHCPv6 client to interface vtnet5 it receives DHCPv6 address plus options.
When I attach my client to interface vtnet3 pfSense simply does not answer.
The only exception is when I send a DHCPv6 solicitation with my old lease not being deleted. I mean the lease that was created when the client was connected to vtnet5. The client stores its ID and sends it to pfSense, getting an IP address but from the wrong (vtnet5) interface's prefix, which is odd I guess. That's just a side effect.

The actual problem is that on vtnet3 solicitations are just being ignored.

This is the corresponding forum thread:
https://forum.netgate.com/topic/146256/regular-crash-dumps/4

This is my config:

        <opt2>
            <descr><![CDATA[DMZ]]></descr>
            <if>vtnet3</if>
            <spoofmac></spoofmac>
            <blockbogons></blockbogons>
            <enable></enable>
            <ipaddr>10.10.133.1</ipaddr>
            <subnet>24</subnet>
            <ipaddrv6>track6</ipaddrv6>
            <track6-interface>wan</track6-interface>
            <track6-prefix-id>20480</track6-prefix-id>
        </opt2>
        <opt4>
            <descr><![CDATA[LCADM]]></descr>
            <if>vtnet5</if>
            <enable></enable>
            <spoofmac></spoofmac>
            <ipaddrv6>track6</ipaddrv6>
            <track6-interface>wan</track6-interface>
            <track6-prefix-id>24580</track6-prefix-id>
        </opt4>
    <dhcpdv6>
        <lan>
            <range>
                <from>::1000</from>
                <to>::2000</to>
            </range>
            <ramode>managed</ramode>
            <rapriority>medium</rapriority>
            <rainterface></rainterface>
            <ravalidlifetime></ravalidlifetime>
            <rapreferredlifetime></rapreferredlifetime>
            <raminrtradvinterval></raminrtradvinterval>
            <ramaxrtradvinterval></ramaxrtradvinterval>
            <raadvdefaultlifetime></raadvdefaultlifetime>
            <radomainsearchlist></radomainsearchlist>
            <prefixrange>
                <from></from>
                <to></to>
                <prefixlength>60</prefixlength>
            </prefixrange>
            <defaultleasetime>84000</defaultleasetime>
            <maxleasetime>164000</maxleasetime>
            <netmask></netmask>
            <domain>my.domain.name</domain>
            <domainsearchlist>my.domain.name</domainsearchlist>
            <enable></enable>
            <ddnsdomain>my.domain.name</ddnsdomain>
            <ddnsdomainprimary>10.10.100.52</ddnsdomainprimary>
            <ddnsdomainkeyname>srv201.my.domain.name</ddnsdomainkeyname>
            <ddnsdomainkey>sdfuiowejionisdofahsdfuiowejionisdofahsdfuiowejionisdofahsdfuiowejionisdofah</ddnsdomainkey>
            <ddnsclientupdates>allow</ddnsclientupdates>
            <tftp></tftp>
            <ldap></ldap>
            <bootfile_url></bootfile_url>
            <dhcpv6leaseinlocaltime>yes</dhcpv6leaseinlocaltime>
            <numberoptions></numberoptions>
            <rasamednsasdhcp6></rasamednsasdhcp6>
            <ddnsupdate></ddnsupdate>
            <ddnsdomainkeyalgorithm>hmac-md5</ddnsdomainkeyalgorithm>
            <dnsserver>2620:fe::fe</dnsserver>
            <dnsserver>2620:fe::9</dnsserver>
            <radnsserver>2620:fe::9</radnsserver>
            <radnsserver>2620:fe::fe</radnsserver>
        </lan>
        <opt1>
            <ramode>managed</ramode>
            <rapriority>medium</rapriority>
            <rainterface></rainterface>
            <ravalidlifetime></ravalidlifetime>
            <rapreferredlifetime></rapreferredlifetime>
            <raminrtradvinterval></raminrtradvinterval>
            <ramaxrtradvinterval></ramaxrtradvinterval>
            <raadvdefaultlifetime></raadvdefaultlifetime>
            <radomainsearchlist></radomainsearchlist>
            <range>
                <from>::1000</from>
                <to>::2000</to>
            </range>
            <prefixrange>
                <from>2000:1111:2222:3000::</from>
                <to>2000:1111:2222:3ff0::</to>
                <prefixlength>60</prefixlength>
            </prefixrange>
            <defaultleasetime></defaultleasetime>
            <maxleasetime></maxleasetime>
            <netmask></netmask>
            <domain></domain>
            <domainsearchlist></domainsearchlist>
            <enable></enable>
            <ddnsdomain></ddnsdomain>
            <ddnsdomainprimary></ddnsdomainprimary>
            <ddnsdomainkeyname></ddnsdomainkeyname>
            <ddnsdomainkey></ddnsdomainkey>
            <ddnsclientupdates>allow</ddnsclientupdates>
            <tftp></tftp>
            <ldap></ldap>
            <bootfile_url></bootfile_url>
            <dhcpv6leaseinlocaltime></dhcpv6leaseinlocaltime>
            <numberoptions></numberoptions>
            <rasamednsasdhcp6></rasamednsasdhcp6>
            <ddnsdomainkeyalgorithm>hmac-md5</ddnsdomainkeyalgorithm>
        </opt1>
        <opt2>
            <range>
                <from>::1000</from>
                <to>::2000</to>
            </range>
            <prefixrange>
                <from></from>
                <to></to>
                <prefixlength>60</prefixlength>
            </prefixrange>
            <defaultleasetime></defaultleasetime>
            <maxleasetime></maxleasetime>
            <netmask></netmask>
            <domain>my.domain.name</domain>
            <domainsearchlist>my.domain.name</domainsearchlist>
            <ddnsdomain></ddnsdomain>
            <ddnsdomainprimary></ddnsdomainprimary>
            <ddnsdomainkeyname></ddnsdomainkeyname>
            <ddnsdomainkey></ddnsdomainkey>
            <ddnsclientupdates>allow</ddnsclientupdates>
            <tftp></tftp>
            <ldap></ldap>
            <bootfile_url></bootfile_url>
            <dhcpv6leaseinlocaltime>yes</dhcpv6leaseinlocaltime>
            <numberoptions></numberoptions>
            <ramode>assist</ramode>
            <rapriority>medium</rapriority>
            <rainterface></rainterface>
            <ravalidlifetime></ravalidlifetime>
            <rapreferredlifetime></rapreferredlifetime>
            <raminrtradvinterval></raminrtradvinterval>
            <ramaxrtradvinterval></ramaxrtradvinterval>
            <raadvdefaultlifetime></raadvdefaultlifetime>
            <radomainsearchlist></radomainsearchlist>
            <rasamednsasdhcp6></rasamednsasdhcp6>
            <ddnsdomainkeyalgorithm>hmac-md5</ddnsdomainkeyalgorithm>
            <enable></enable>
            <dnsserver>2620:fe::9</dnsserver>
            <dnsserver>2620:fe::fe</dnsserver>
            <radnsserver>2620:fe::fe</radnsserver>
            <radnsserver>2620:fe::9</radnsserver>
        </opt2>
        <opt4>
            <range>
                <from>::1000</from>
                <to>::2000</to>
            </range>
            <prefixrange>
                <from>2000:1111:2222:3000::</from>
                <to>2000:1111:2222:3ff0::</to>
                <prefixlength>60</prefixlength>
            </prefixrange>
            <defaultleasetime>72000</defaultleasetime>
            <maxleasetime>148000</maxleasetime>
            <netmask></netmask>
            <domain>another.domain</domain>
            <domainsearchlist>another.domain</domainsearchlist>
            <ddnsdomain>another.domain</ddnsdomain>
            <ddnsdomainprimary>10.10.100.52</ddnsdomainprimary>
            <ddnsdomainkeyname>srv201.my.domain.name</ddnsdomainkeyname>
            <ddnsdomainkeyalgorithm>hmac-md5</ddnsdomainkeyalgorithm>
            <ddnsdomainkey>sdfuiowejionisdofahsdfuiowejionisdofahsdfuiowejionisdofahsdfuiowejionisdofah</ddnsdomainkey>
            <ddnsclientupdates>allow</ddnsclientupdates>
            <tftp></tftp>
            <ldap></ldap>
            <bootfile_url></bootfile_url>
            <dhcpv6leaseinlocaltime></dhcpv6leaseinlocaltime>
            <numberoptions></numberoptions>
            <ramode>assist</ramode>
            <rapriority>high</rapriority>
            <rainterface></rainterface>
            <ravalidlifetime></ravalidlifetime>
            <rapreferredlifetime></rapreferredlifetime>
            <raminrtradvinterval></raminrtradvinterval>
            <ramaxrtradvinterval></ramaxrtradvinterval>
            <raadvdefaultlifetime></raadvdefaultlifetime>
            <radomainsearchlist></radomainsearchlist>
            <rasamednsasdhcp6></rasamednsasdhcp6>
            <ddnsupdate></ddnsupdate>
            <enable></enable>
            <staticmap>
                <duid>00:04:02:4f:c3:17:d7:ef:42:0c:b2:2a:4f:5c:31:5a:1c:d3</duid>
                <ipaddrv6>::2001</ipaddrv6>
                <hostname>debian1</hostname>
                <descr><![CDATA[debian1 virtucom lcadm vlan 300]]></descr>
                <filename></filename>
                <rootpath></rootpath>
            </staticmap>
            <dnsserver>2620:fe::fe</dnsserver>
            <dnsserver>2620:fe::9</dnsserver>
            <radnsserver>2000:1111:2222:6004:5054:ff:fe9f:38cf</radnsserver>
        </opt4>
        <opt5>
            <ramode>managed</ramode>
            <rapriority>low</rapriority>
            <rainterface></rainterface>
            <ravalidlifetime></ravalidlifetime>
            <rapreferredlifetime></rapreferredlifetime>
            <raminrtradvinterval></raminrtradvinterval>
            <ramaxrtradvinterval></ramaxrtradvinterval>
            <raadvdefaultlifetime></raadvdefaultlifetime>
            <radomainsearchlist></radomainsearchlist>
            <range>
                <from>::1000</from>
                <to>::2000</to>
            </range>
            <prefixrange>
                <from>2000:1111:2222:4000::</from>
                <to>2000:1111:2222:4ff0::</to>
                <prefixlength>60</prefixlength>
            </prefixrange>
            <defaultleasetime></defaultleasetime>
            <maxleasetime></maxleasetime>
            <netmask></netmask>
            <domain></domain>
            <domainsearchlist></domainsearchlist>
            <enable></enable>
            <ddnsdomain></ddnsdomain>
            <ddnsdomainprimary></ddnsdomainprimary>
            <ddnsdomainkeyname></ddnsdomainkeyname>
            <ddnsdomainkeyalgorithm>hmac-md5</ddnsdomainkeyalgorithm>
            <ddnsdomainkey></ddnsdomainkey>
            <ddnsclientupdates>allow</ddnsclientupdates>
            <tftp></tftp>
            <ldap></ldap>
            <bootfile_url></bootfile_url>
            <dhcpv6leaseinlocaltime></dhcpv6leaseinlocaltime>
            <numberoptions></numberoptions>
            <dnsserver>2620:fe::fe</dnsserver>
            <dnsserver>2620:fe::9</dnsserver>
            <staticmap>
                <duid>00:03:00:01:9e:fd:47:a1:73:32</duid>
                <ipaddrv6>::2001</ipaddrv6>
                <hostname>debian1</hostname>
                <descr><![CDATA[debian1 virtucom lcadm vlan 300]]></descr>
                <filename></filename>
                <rootpath></rootpath>
            </staticmap>
        </opt5>
    </dhcpdv6>

dhcpv6_not_being_answered.png (74.3 KB) dhcpv6_not_being_answered.png Pim Pish, 09/04/2019 03:53 AM

History

#1 Updated by Pim Pish 6 months ago

I cannot reproduce this any more. I don't know how this happened but now it's working.

#2 Updated by Jim Pingle 6 months ago

  • Status changed from New to Not a Bug
  • Priority changed from High to Normal

Also available in: Atom PDF