Project

General

Profile

Actions

Bug #9747

closed

IPsec widget - Missing escape of domain backslash

Added by Sebastian Fiebig about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Very Low
Category:
Dashboard
Target version:
Start date:
09/11/2019
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.4-p3
Affected Architecture:

Description

The IPSec widget does not work as soon as one user, e.g., from a windows domain with a username like "domain\user" has logged in via IPSec. In this case the widget information just never renders the information on all three tabs, because an exception is thrown in JS. The problem is the non valid usage of a backslash in the username respectively the missing escaping.

The problem is introduced in https://github.com/pfsense/pfsense/blob/v2.4.4_3/src/usr/local/www/widgets/widgets/ipsec.widget.php#L167 and leads to an error with JSON.parse(s) here https://github.com/pfsense/pfsense/blob/v2.4.4_3/src/usr/local/www/widgets/widgets/ipsec.widget.php#L311

I'm going to create a small pull request, that just fixes the backslash escaping at server side. I'm not a PHP expert, so there may be a better solution.

Actions #2

Updated by Jim Pingle about 2 years ago

  • Status changed from New to Pull Request Review
Actions #3

Updated by Renato Botelho about 2 years ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • Target version set to 2.5.0
  • % Done changed from 0 to 100

PR has been merged. Thanks

Actions #4

Updated by Jim Pingle about 2 years ago

  • Target version changed from 2.5.0 to 2.4.5
Actions #5

Updated by Jim Pingle almost 2 years ago

  • Subject changed from IPSec widget - Missing escape of domain backslash to IPsec widget - Missing escape of domain backslash
  • Status changed from Feedback to Resolved

No feedback from OP but the widget is working fine in general, so likely fixed.

Actions

Also available in: Atom PDF