Project

General

Profile

Bug #9930

Dpinger fills log with sendto errors when VPN is down

Added by Flole Systems about 1 year ago. Updated about 1 year ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Gateway Monitoring
Target version:
-
Start date:
11/27/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

I have configured a tinc VPN Interface and I have a Gateway on that connection. If the remote host goes down (meaning that it disconnects from tinc) I am seeing thousands of

dpinger        MyGW x.x.x.x: sendto error: 64

entries in the log, which cause the important and useful entries to disappear. As there are 2 of these entries per second it doesn't make any sense to increase the log file size because even the biggest log file will start overwriting itself after a short time. dpinger should implement some kind of throttling of messages, like for example combining various messages into a "message repeated x time" or it should not show these messages at all.

History

#1 Updated by Jim Pingle about 1 year ago

  • Category set to Gateway Monitoring
  • Status changed from New to Not a Bug
  • Target version deleted (2.5.0)

We do not maintain dpinger, if you want to suggest a change to dpinger, raise it on their bug tracker: https://github.com/dennypage/dpinger/issues

Also, the logging changed on 2.5.0, so it's possible it's not even an issue there since the logs are no longer circular, but rotated.

Also available in: Atom PDF