Project

General

Profile

Actions

Bug #995

closed

New x64 snapshots won't boot

Added by Peter O about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Operating System
Target version:
Start date:
11/04/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

The 2 latest x64 snapshots won't boot. They give the error "Cannot dump. Device not defined or unavailable" ("Automatic reboot in 15 seconds").

The cd installer won't boot. Updating an installation of pfSense-2.0-BETA4-20101102-0300.iso.gz to the latest version also fails to boot after update.

These are the images that won't work:
http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/amd64/pfSense_HEAD/livecd_installer/pfSense-2.0-BETA4-20101104-0143.iso.gz
http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/amd64/pfSense_HEAD/livecd_installer/pfSense-2.0-BETA4-20101103-2032.iso.gz

Working down, one image older does work:
http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/amd64/pfSense_HEAD/livecd_installer/pfSense-2.0-BETA4-20101103-1517.iso.gz


Files

normal_boot.png (54.9 KB) normal_boot.png Booting in Normal Mode Peter O, 11/04/2010 11:00 AM
no_acpi_boot.png (49.6 KB) no_acpi_boot.png Booting with ACPI disabled Peter O, 11/04/2010 11:00 AM
safe_mode_boot.png (55.3 KB) safe_mode_boot.png Booting in Safe Mode Peter O, 11/04/2010 11:00 AM
single_user_boot.png (53.9 KB) single_user_boot.png Booting in Single User Mode Peter O, 11/04/2010 11:00 AM
verbose_boot.png (64.1 KB) verbose_boot.png Booting with Verbose Loggin Peter O, 11/04/2010 11:00 AM
amd64_panic_bt.png (36.1 KB) amd64_panic_bt.png Jim Pingle, 11/07/2010 06:43 PM
Actions #1

Updated by Jim Pingle about 11 years ago

  • Category set to Operating System
  • Priority changed from Normal to High
  • Target version set to 2.0
  • Affected Version set to 2.0

This is likely due to some recent performance patches added into the tree that behave OK on i386 but apparently not on amd64.

Actions #2

Updated by Jim Pingle about 11 years ago

Attaching a screencap of a panic+backtrace from booting a dev kernel on amd64

Actions #3

Updated by Ermal Luçi about 11 years ago

  • Status changed from New to Feedback

This should be fixed from latest commits.

Actions #4

Updated by Jim Pingle about 11 years ago

Confirmed. New snapshot just uploaded boots OK in my amd64 VM.
2.0-BETA4 (amd64)
built on Tue Nov 9 17:26:01 UTC 2010

Actions #5

Updated by Ermal Luçi about 11 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF