Project

General

Profile

Bug #9975

PHP error on upgrade from 2.4.4-p3 to 2.4.5

Added by Jim Pingle 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
Upgrade
Target version:
Start date:
12/17/2019
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.5
Affected Architecture:
All

Description

The following PHP errors come up when upgrading from 2.4.4-p3 to 2.4.5. They are not harmful, but are due to the library version changing. If we can suppress these, it would reduce support questions.

PHP Errors:
[17-Dec-2019 15:01:21 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'readline.so' (tried: /usr/local/lib/php/20170718/readline.so (Shared object "libreadline.so.7" not found, required by "readline.so"), /usr/local/lib/php/20170718/readline.so.so (Cannot open "/usr/local/lib/php/20170718/readline.so.so")) in Unknown on line 0
[17-Dec-2019 15:01:41 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'readline.so' (tried: /usr/local/lib/php/20170718/readline.so (Shared object "libreadline.so.7" not found, required by "readline.so"), /usr/local/lib/php/20170718/readline.so.so (Cannot open "/usr/local/lib/php/20170718/readline.so.so")) in Unknown on line 0
[17-Dec-2019 15:01:43 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'readline.so' (tried: /usr/local/lib/php/20170718/readline.so (Shared object "libreadline.so.7" not found, required by "readline.so"), /usr/local/lib/php/20170718/readline.so.so (Cannot open "/usr/local/lib/php/20170718/readline.so.so")) in Unknown on line 0
[17-Dec-2019 15:02:08 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'readline.so' (tried: /usr/local/lib/php/20170718/readline.so (Shared object "libreadline.so.7" not found, required by "readline.so"), /usr/local/lib/php/20170718/readline.so.so (Cannot open "/usr/local/lib/php/20170718/readline.so.so")) in Unknown on line 0
[17-Dec-2019 15:02:09 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'readline.so' (tried: /usr/local/lib/php/20170718/readline.so (Shared object "libreadline.so.7" not found, required by "readline.so"), /usr/local/lib/php/20170718/readline.so.so (Cannot open "/usr/local/lib/php/20170718/readline.so.so")) in Unknown on line 0

History

#1 Updated by Renato Botelho about 2 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

pfSense-upgrade 0.70 should fix this

#2 Updated by Jim Pingle about 2 months ago

  • Status changed from Feedback to Resolved

No PHP errors observed after upgrading from 2.4.4-p3 to 2.4.5.a.20200108.0835

Also available in: Atom PDF