Project

General

Profile

Bug #9984

PHP error in 2.4.5 services_dyndns_edit.php

Added by Tom Embt 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Dynamic DNS
Target version:
Start date:
12/19/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.5
Affected Architecture:
All

Description

RELENG_2_4_5 has a PHP syntax error when trying to add a Dynamic DNS client (just clicking the green Add button will show it).

Parse error: syntax error, unexpected '&&' (T_BOOLEAN_AND) in /usr/local/www/services_dyndns_edit.php on line 76

This problem existed on master and was updated with 1c11171b, however we should probably not cherry-pick that commit as it was not just a syntax fix but actually changed the functionality of the code. It would appear that on master the more recent ticket #9452 fixed the error introduced with 1c11171b

History

#1 Updated by Tom Embt 2 months ago

Seen in:
2.4.5-DEVELOPMENT (amd64)
built on Wed Dec 18 23:54:57 EST 2019

#2 Updated by Jim Pingle 2 months ago

  • Category set to Dynamic DNS
  • Status changed from New to In Progress
  • Assignee set to Jim Pingle
  • Priority changed from Normal to High
  • Target version set to 2.4.5
  • Affected Version set to 2.4.5
  • Affected Architecture All added
  • Affected Architecture deleted ()

#3 Updated by Jim Pingle 2 months ago

I applied all the missing commits from master (including the ones you mentioned, plus edfe22f8bae894eb678f3e7060cc91cea6f664da) which should bring it all the way in line. I no longer see the error with these changes.

Try it again once a snapshot includes the fix.

#4 Updated by Jim Pingle 2 months ago

  • Status changed from In Progress to Feedback

#5 Updated by Tom Embt 2 months ago

Can confirm - the issue is fixed in a newer snapshot

#6 Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to Resolved

Thanks for testing!

Also available in: Atom PDF