General

Profile

Adam Thompson

Issues

Activity

11/05/2018

02:36 PM pfSense Bug #9097 (New): ECL can't locate config.xml unless device is MBR-partitioned
Follow-on to #9089, but this one needs to be fixed in code, IMHO:
* GPT devices show up as da1p1, not da1s1, so ca...

11/02/2018

04:39 PM pfSense Docs Correction #9089 (Resolved): ECL can't locate config.xml unless USB device is partitioned
The glob() pattern in source:src/etc/ecl.php#L40 's get_disk_slices() implicitly limits the function to finding confi...

08/15/2018

12:56 PM pfSense Bug #8787 (Closed): vmware Appliance OVA template creates VMs that VEEAM cannot backup and restore successfully
Affected version: every version we've tested so far, at least as far back as ~2.2.0, right through current 2.4 releas...

07/16/2018

10:06 AM pfSense Feature #8641: Need way to disable HSTS and/or replace webConfigurator certificate from CLI
While I now feel like a complete idiot, thank you for reminding me of the same advice I give to my own developers. S...

07/13/2018

08:57 AM pfSense Feature #8645 (Pull Request Review): Upload certificate file instead of pasting
When importing a new certificate, currently we have to paste in the ASCII Base64 (PEM) representation of the cert & k...
07:32 AM pfSense Feature #8641: Need way to disable HSTS and/or replace webConfigurator certificate from CLI
Thanks, Jim - that is +much+ easier to type through a bad console connection! (Particularly since I just realized I'...

07/12/2018

05:25 PM pfSense Feature #8641: Need way to disable HSTS and/or replace webConfigurator certificate from CLI
And yes, I'd be happy to _also_ write up a KB-style or doc-style page showing admins how to un-f*** themselves in thi...
05:23 PM pfSense Feature #8641: Need way to disable HSTS and/or replace webConfigurator certificate from CLI
Yes, I'm aware of both #6650 and https://github.com/pfsense/pfsense/pull/3856, and I was able to find the Disable HST...
05:22 PM pfSense Feature #8641 (New): Need way to disable HSTS and/or replace webConfigurator certificate from CLI
On a 2.4.2-RELEASE firewall, which still sets the HSTS headers, I had a wildcard certificate installed, and it just e...

07/05/2018

07:51 AM pfSense Bug #8518: Rule Error On Upgrade 2.4.3 -> 2.4.3-p1
Still hitting this bug with no working solution in 2.4.3_p1, but it's fixed in 2.4.4.a.20180705.0739 , at least on th...

Also available in: Atom