Project

General

Profile

Feature #10388

Upgrade to Python 3.8

Added by retnikt the 7 months ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Operating System
Target version:
Start date:
03/29/2020
Due date:
% Done:

0%

Estimated time:

Description

I saw that in pfSense 2.5.0, Python will be upgraded from 2.7 to 3.6. Why not upgrade to the latest version (currently 3.8.2)? It's perfectly stable, and the only major breaking changes are relating to asyncio which I believe is not used in pfSense or any of its packages. More information can be found here and here

History

#1 Updated by Jim Pingle 7 months ago

  • Target version set to 2.5.0

It's already at python 3.7.x on pfSense 2.4.5-RELEASE and pfSense 2.5.0 snapshots. AFAIK we're using whatever the default version is for python 3.x on FreeBSD. Currently that is 3.7.

We can consider this for pfSense 2.5.0, but we'd need to check over things to be certain it wouldn't have a negative impact.

#2 Updated by Renato Botelho about 1 month ago

  • Status changed from New to Rejected

We will keep following the default version from FreeBSD ports tree, which now is 3.7

Also available in: Atom PDF