Project

General

Profile

Bug #10396

rc.start_packages after modem loose connection

Added by odo maitre about 2 months ago. Updated about 2 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
03/31/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.5
Affected Architecture:

Description

Hello,
I found this issue in conjunction with Snort and after a discussion with bmeeks (https://forum.netgate.com/topic/151807/snort-not-restart-on-interface/3) we found out that the probable culprit sits in the "rc.start_packages" Script.
The issue: after a Sync outage of the DSL Modem (it can be caused also from a Modem power outage) the internet gets lost and when the Modem syncs again and the the connection gets reestablished I have see that in the dmesg is missing a line that normally is here when pppoe reestablish the connection: "ng0: changing name to 'pppoe0'" This missing line causes Snort not to restart on the Wan Connection. I suppose that ther is something in the "rc.start_packages" Script that causes this behaviour.
I hope I have described as good as possible the issue.
BTW: this is my first post on redmine so please be gentle ... :-)

Thanks in advance,
pfsense23user

History

#1 Updated by Jim Pingle about 2 months ago

  • Status changed from New to Incomplete

There is not nearly enough information here for a valid bug report. Please keep the discussion on your forum thread until a bug has been more positively identified.

You need to provide the logs from when it works compared to when it doesn't work. You mentioned one line that appears and is missing in certain cases but there is no context to exactly when that happens or what conditions led to it.

You need to provide a lot more information about how to reproduce the problem as well. For example, does it happen when you power the modem off/on? Or from a signal loss? Or only if the ISP disconnects you?

The output of "ifconfig -a" when it works and when it doesn't work would also be helpful to see.

rc.start_packages most likely is not the problem here. If there is an issue with the PPPoE interface not being renamed, that would most likely be in MPD or netgraph. rc.start_packages would only be (re)starting packages as a consequence of the interface event. It doesn't have anything to do with setting up the interface itself.

#2 Updated by Bill Meeks about 2 months ago

After some further research and back and forth posts in the forum thread on this issue, I am pretty confident it is not a problem with the rc.start_packages script or with the Snort package either. Something is causing the PPPoE virtual interface to disappear under certain scenarios on the user's system and not get recreated when the ISP connectivity returns. When Snort can't find the configured interface, then it will fail to start.

Bill

#3 Updated by odo maitre about 2 months ago

I think it can be closed. After some further investigations I am sure it is not a problem with the rc.start_packages script or with the Snort package, it seems to be a timing problem that in this special situation creates the problem.

Thanks for your attention!

Regards,
pfsense23user

#4 Updated by Jim Pingle about 2 months ago

  • Status changed from Incomplete to Not a Bug

OK, if you do manage to track down the source of the problem and have enough detail for others to reproduce it and so on, open a fresh issue with all of that info. Thanks!

Also available in: Atom PDF