Project

General

Profile

Bug #10407

L2TP static route not re-added after connection down/up

Added by Federico Chiaravalli about 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
L2TP
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Affected Version:
Affected Architecture:
Release Notes:
Default

Description

How to recreate:
Create L2TP VPN
Create a default gw to the VPN subnet
Create the static route
  • route is added to diagnostics -> routes
    Disconnect from VPN
  • route is deleted from diagnostics -> routes
    Reconnect to VPN
  • route is not re-added
    Disable the static route
    Enable the static route
  • route is added to diagnostics -> routes

The static route should be automatically re-added when the L2TP interface is up.
I'm not sure if this is an intended behaviour, I googled it, and I didn't found anything related to this - so I assume that this is a bug.

Associated revisions

Revision 05af3262 (diff)
Added by Viktor Gurov 5 months ago

Auto add static routes for PPP interfaces. Fixes #10407

History

#2 Updated by Jim Pingle about 1 year ago

  • Category set to Interfaces
  • Status changed from New to Needs Patch
  • Start date deleted (04/01/2020)

The L2TP WAN-type interface design is not designed to be used with VPNs. It may work, but not intentionally. It is designed to be used for ISPs which require it for WAN connectivity.

Though the routing behavior as stated is undesirable, I don't see us putting internal resources toward supporting this use case.

If someone wants to submit a PR to correct the behavior, we can certainly consider it.

#4 Updated by Jim Pingle 5 months ago

  • Status changed from Needs Patch to Pull Request Review
  • Target version set to 2.5.0
  • Affected Version deleted (2.5.0)

#5 Updated by Renato Botelho 5 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Viktor Gurov

PR has been merged. Thanks!

#6 Updated by Viktor Gurov 5 months ago

  • % Done changed from 0 to 100

#7 Updated by Jim Pingle 5 months ago

  • Category changed from Interfaces to L2TP

#8 Updated by Alhusein Zawi 5 months ago

route is not deleted if reconnecting.

Static route will be deleted if L2TP interface is down.

Static route will be added if L2TP interface is up/reconnected.

2.5.0.a.20201118.1850

#9 Updated by Alhusein Zawi 5 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF