Project

General

Profile

Actions

Bug #10553

closed

Gateway Groups Tier 2 fail dropping states on Tier 1 connection

Added by Daniel Subert over 1 year ago. Updated over 1 year ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Gateway Monitoring
Target version:
-
Start date:
05/13/2020
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.4-p3
Affected Architecture:

Description

Symptom:
State drops occurring incorrectly in certain fail-over conditions

Setup:
Gateway Group with 2 gateways setup in tiers:
WAN1 = Tier 1
WAN2 = Tier 2

Online status change on WAN2 causes state drop of WAN1 states

To recreate the bug:

  1. 1. Establish a state over WAN1 (HTTP/SSH/RDP etc)
  2. 2. Introduce packet loss or disconnect WAN2
  • (dpinger may also log that packet loss is occuring on WAN1!)
  1. 3. States on WAN1 will drop

Notes:
Where a status change (up/down/packet loss/etc) on WAN1 occurs, states on WAN2 are unaffected.

Actions #1

Updated by Jim Pingle over 1 year ago

  • Category set to Gateway Monitoring
  • Status changed from New to Not a Bug

That's the expected behavior currently. There is no way to have it only kill states for connections on a specific WAN/gateway.

There is already a request to enhance that open at #8555

Actions #2

Updated by Daniel Subert over 1 year ago

Hi Jim,

Is dpinger aware of the gateway groups tiers?

The states should only be dropped if the active tier is down. For example:
  • If Tier 1 and Tier 2 is up, all states will be on the Tier 1 gateway.
  • If Tier 2 gateway then fails, there are no states on the Tier 2 gateway to drop, so there should be no action.

Thus dpinger could be told that if the tier with the failure is not the current tier, do nothing.

Possibly overlooked is the fact that dpinger has marked WAN1 on Tier 1 as packet loss / down when WAN2 has issues. In our testing WAN1 definitely does not have any packet loss or connectivity issue despite dpingers report to the contrary.

Please consider reviewing support ticket 51437, the support team advised us to register a bug report for the behavior we are observing.

I'm very confident that there is some unintended behavior here.

Actions

Also available in: Atom PDF