Project

General

Profile

Actions

Bug #10577

open

intel x553 (c3000 chipset) loading x520 driver

Added by Peter Martens over 1 year ago. Updated over 1 year ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Category:
Hardware / Drivers
Target version:
-
Start date:
05/20/2020
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

We have an supermicro (SYS-5019A-FTN4) based on the c3000 serie cpu (atom C3758) with 2.4.5-RELEASE pfsense on the system).
I use 2 of the onboard ports (intel x553 on chipset) for WAN and LAN. after installing a intel x520 10gb network card, all the ports stopped working.

I have found the same issue on reddit: https://www.reddit.com/r/PFSENSE/comments/az710b/intel_520_driver_loading_for_intel_553/ (setting fixed interface speed under: setting interface -> Speed and Duplex to 1000baseT as mentioned on this thread didn't fix the issue for me).

I tried to setup the interfaces again, but automatic detection of the interface failed (always down).

it seems a bug in the driver. after removing the x520 card the system is back to normal.


Files

uefi_network_card_overview.jpg (2.5 MB) uefi_network_card_overview.jpg Peter Martens, 05/20/2020 06:37 AM
interfaces_down_cant_set_interface.jpg (2.94 MB) interfaces_down_cant_set_interface.jpg Peter Martens, 05/20/2020 06:41 AM
system.log (500 KB) system.log Peter Martens, 05/20/2020 10:09 AM
dmesg log (without card).txt (12.5 KB) dmesg log (without card).txt Peter Martens, 05/20/2020 10:09 AM
loader.conf (without card).txt (267 Bytes) loader.conf (without card).txt Peter Martens, 05/20/2020 10:09 AM
netstat -m (without card).txt (1.09 KB) netstat -m (without card).txt Peter Martens, 05/20/2020 10:09 AM
sysctl kern.ipc.nmbclusters (without card).txt (29 Bytes) sysctl kern.ipc.nmbclusters (without card).txt Peter Martens, 05/20/2020 10:10 AM
Actions

Also available in: Atom PDF