Project

General

Profile

Feature #10597

Setting host-uniq for PPPoE

Added by Viktor Gurov 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Category:
PPP Interfaces
Target version:
Start date:
05/27/2020
Due date:
% Done:

100%

Estimated time:

Description

https://forum.netgate.com/topic/153911/setting-host-uniq-for-pppoe:
"My ISP uses the host-uniq part of the PPPoE PADI packet to authenticate the system before any communication. How can I set this value in PfSense?"

it's already supported by FreeBSD: https://reviews.freebsd.org/D9270

from https://www.freebsd.org/cgi/man.cgi?query=ng_pppoe&apropos=0&sektion=0&manpath=FreeBSD+11.3-RELEASE&arch=default&format=html:

NGM_PPPOE_CONNECT (pppoe_connect)
      Tell a nominated newly created hook that its session should enter
      the state machine as a client.  It must be newly created and a ser-
      vice name can    be given as an argument.  It is    legal to specify a
      zero-length service name, this is common on some DSL setups.    It is
      possible to request a    connection to a    specific access    concentrator,
      and/or set a specific    Host-Uniq tag, required    by some    Internet
      providers, using the "[AC-Name][Host-Uniq|]Service-Name" syntax.  To
      set a    binary Host-Uniq, it must be encoded as    a hexadecimal lower-
      case string and prefixed with    "0x", for example "0x6d792d746167" is
      equivalent to    "my-tag".  A session request packet will be broadcast
      on the Ethernet.  This command uses the ngpppoe_init_data structure
      shown    below.    For example, this init data argument can be used to
      connect to "my-isp" service with "my-host" uniq tag, accepting only
      "remote-ac" as access    concentrator:

        "remote-ac\my-host|my-isp" 

need WebGUI option

Associated revisions

Revision 71465708 (diff)
Added by Viktor Gurov 5 months ago

Setting host-uniq for PPPoE. Implements #10597

History

#2 Updated by Jim Pingle 5 months ago

  • Status changed from New to Pull Request Review
  • Target version set to 2.5.0

#3 Updated by Renato Botelho 5 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • % Done changed from 0 to 100

PR has been merged. Thanks!

#4 Updated by Louis van Breda 4 months ago

Hello,

A few days ago I updated 2.5 and ..... what broke my PPPOE connection (fatal). I have a strong verdict that it is related to this patch.

I did some tests:

- I did a clean install (disk formatted) from the today version pfSense-CE-memstick-2.5.0-DEVELOPMENT-amd64-20200615-0050.img.gz
> FAILED NO PPPOE
- Then I did a clean install (disk formatted) of pfSense-CE-memstick-2.5.0-DEVELOPMENT-amd64-20200611-1250.img.gz
> That one was still working

So something whent wrong between 20200611 and 20200614 release and it is not fixed in the 20200615 release.

I also discussed the issue in the forum "Todays (14/6) build broke PPPOE-internet connection (FATAL !!)"

Please investigate!

Louis

#5 Updated by Louis van Breda 4 months ago

Hello,

It looks like I found the problem. The solution was quite simple, however it did cost me nearly two days to find it. Lots of try and testing!

In the WAN interface there is a field MTU, that field was in my case always empty ..... that does not work any longer, at least not in my case.

Setting MTU to 1508 did the job for he. So simple ..... if you know what the problem is ....

Question is why is suddenly required to fill that field.... !!??

Lets be glad I found the problem!

Louis

#6 Updated by Viktor Gurov 4 months ago

  • Status changed from Feedback to Resolved

correctly sets Host-Uniq value on 2.5.0.a.20200617.1250:

PPP-over-Ethernet Discovery
    0001 .... = Version: 1
    .... 0001 = Type: 1
    Code: Active Discovery Initiation (PADI) (0x09)
    Session ID: 0x0000
    Payload Length: 23
    PPPoE Tags
        Host-Uniq: 111111111111111111111111111111

The "MTU 1508 PPPoE" issue is not related to this feature

Also available in: Atom PDF