Project

General

Profile

Actions

Bug #10661

closed

pfSense configures fe80::1:1 on lan interface without track6

Added by Viktor Gurov over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
06/13/2020
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.5-p1
Affected Architecture:

Description

While creating CARP IPv6 VIP interface on clean pfSense CE 2.4.5-p1 install,
I noticed that both nodes have fe80::1:1 address:

# ifconfig vtnet0
vtnet0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=80028<VLAN_MTU,JUMBO_MTU,LINKSTATE>
    ether 0c:c5:49:d7:8c:00
    hwaddr 0c:c5:49:d7:8c:00
    inet6 fe80::1:1%vtnet0 prefixlen 64 scopeid 0x1
    inet6 fc00:3::51 prefixlen 64
    inet6 fc00:3::55 prefixlen 64 vhid 2
    inet 192.168.3.51 netmask 0xffffff00 broadcast 192.168.3.255
    inet 192.168.3.55 netmask 0xffffff00 broadcast 192.168.3.255 vhid 1
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet 10Gbase-T <full-duplex>
    status: active
    carp: MASTER vhid 1 advbase 1 advskew 0
    carp: MASTER vhid 2 advbase 1 advskew 0

and secondary node:

# ifconfig vtnet0
vtnet0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=80028<VLAN_MTU,JUMBO_MTU,LINKSTATE>
    ether 0c:c5:49:26:9f:00
    hwaddr 0c:c5:49:26:9f:00
    inet6 fe80::1:1%vtnet0 prefixlen 64 duplicated scopeid 0x1
    inet6 fc00:3::52 prefixlen 64
    inet6 fc00:3::55 prefixlen 64 vhid 2
    inet 192.168.3.52 netmask 0xffffff00 broadcast 192.168.3.255
    inet 192.168.3.55 netmask 0xffffff00 broadcast 192.168.3.255 vhid 1
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet 10Gbase-T <full-duplex>
    status: active
    carp: BACKUP vhid 1 advbase 1 advskew 100
    carp: MASTER vhid 2 advbase 1 advskew 100

both nodes have static IPv6 addresses, and no any other IPv6 addresses - WAN is DHCP (IPv4), and SYNC interface is Static IPv4

I don't this is a CARP/HA issue, it seems to be a bug with link_interface_to_track6() or interface_track6_configure() and clean config

Actions

Also available in: Atom PDF