Project

General

Profile

Bug #10674

Port Forward Address Fields not becoming active in Safari

Added by Chris Linstruth 10 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
Rules / NAT
Target version:
Start date:
06/18/2020
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.5-p1
Affected Architecture:
Release Notes:
Default

Description

When you select a method that should allow address/network/alias input in a NAT Port Forward in Safari, the fields are not made active.

Tested in Safari 13.1.1 on macOS 10.14.6.

Screenshot attached.

Thank you.

Associated revisions

Revision 66c614af (diff)
Added by Steve Beaver 10 months ago

Fixed #10674 byt replacing .click() with .change()

History

#1 Updated by Chris Linstruth 10 months ago

Same on recent 2.5.0.

#2 Updated by Kris Phillips 10 months ago

Tested working on Firefox. Field updates as expected.

#3 Updated by Steve Beaver 10 months ago

  • Status changed from New to Assigned
  • Assignee set to Steve Beaver

#4 Updated by Steve Beaver 10 months ago

  • Status changed from Assigned to Feedback

#5 Updated by Steve Beaver 10 months ago

  • % Done changed from 0 to 100

#6 Updated by Steve Beaver 10 months ago

  • Assignee changed from Steve Beaver to Chris Linstruth

#7 Updated by Michael Spears 7 months ago

Unable to reproduce on Safari 13.1.2 with pfSense 2.5.0.a.20200910.1250

#8 Updated by Chris Linstruth 6 months ago

  • Status changed from Feedback to Closed
  • Target version set to 2.5.0

Looks good in Safari 14.0 on 10.15.7.

Setting as target version 2.5.0 for release notes or cherry-picking if necessary.

Closing.

#9 Updated by Jim Pingle 5 months ago

  • Category changed from Web Interface to Rules / NAT

Also available in: Atom PDF