Project

General

Profile

Actions

Bug #10675

closed

DHCPv6 config not all directives start on a new line as expected

Added by Jim Pingle over 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DHCP (IPv6)
Target version:
Start date:
06/18/2020
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:
All

Description

In the DHCPv6 config, "prefix6" is not starting on its own new line. Probably the line before is missing a \n at the end of the string it builds.

subnet6 2001:db8::/64 {
    range6 2001:db8::FFFF:0000 2001:db8::FFFF:FFFF;
    do-forward-updates false;
    option dhcp6.name-servers 2001:db8::1;    prefix6 2001:db8:1:E000:: 2001:db8:1:EF00:: /60;

}
Actions #1

Updated by Jim Pingle over 1 year ago

  • Description updated (diff)
Actions #3

Updated by Jim Pingle over 1 year ago

  • Status changed from Confirmed to Pull Request Review
Actions #4

Updated by Renato Botelho over 1 year ago

  • Status changed from Pull Request Review to Feedback

PR has been merged. Thanks!

Actions #5

Updated by Danilo Zrenjanin about 1 year ago

Tested on :

2.5.0-DEVELOPMENT (amd64)
built on Sat Oct 10 01:03:57 EDT 2020
FreeBSD 12.2-STABLE

"prefix6" is starting on its own new line now, though DNS server is not listed anymore.

subnet6 2001:db8::/64 {
    range6 2001:db8::FFFF:0000 2001:db8::FFFF:FFFF;
    do-forward-updates false;
    #option dhcp6.name-servers --;
    prefix6 2001:db8:1:E000:: 2001:db8:1:EF00:: /60;

Please check that.

Actions #6

Updated by Steve Beaver about 1 year ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Jim Pingle to Renato Botelho
Actions #7

Updated by Steve Beaver about 1 year ago

  • Assignee changed from Renato Botelho to Viktor Gurov
Actions #8

Updated by Viktor Gurov about 1 year ago

the original issue seems to be specific for snapshot 2.5 (not 2.4.5),
now it's OK, all directives start on a new line
Resolved

Actions #9

Updated by Steve Beaver about 1 year ago

  • Status changed from In Progress to Resolved
Actions #10

Updated by Jim Pingle about 1 year ago

Looks good to me as well, including the DNS server.

subnet6 2001:db8::/64 {
    range6 2001:db8::FFFF:0000 2001:db8::FFFF:FFFF;
    do-forward-updates false;
    option dhcp6.name-servers 2001:db8::1;
    prefix6 2001:db8:1:E000:: 2001:db8:1:EF00:: /60;

}
Actions #11

Updated by Jim Pingle 12 months ago

  • Category changed from DHCP (IPv4) to DHCP (IPv6)
Actions

Also available in: Atom PDF