Project

General

Profile

Bug #1118

Adding NAT rule based on a NAT rule moves it to bottom of list

Added by Chris Buechler over 8 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Very Low
Category:
Rules/NAT
Target version:
Start date:
12/20/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

When adding a new NAT rule based on another NAT rule, it adds the new one to the bottom of the list. Doesn't matter much, but it should have the same behavior as on firewall rules where it adds it beneath the rule it was based on.

Associated revisions

Revision 3202763c (diff)
Added by Renato Botelho over 6 years ago

Add NAT rule based on NAT rule below it instead of at the bottom of the list. Fixes #1118

Revision 5d764d64 (diff)
Added by Renato Botelho over 6 years ago

Insert new NAT rules on the top of the list when top plus icon is used. Fixes #1118

History

#1 Updated by Renato Botelho over 6 years ago

  • Assignee set to Renato Botelho
  • Target version set to 2.1

#2 Updated by Jim Pingle over 6 years ago

Slightly related: using the + at the top of the NAT rules list adds the rule to the bottom, not the top. (could make a separate ticket for that but it may be the same/similar root cause).

#3 Updated by Renato Botelho over 6 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#5 Updated by Renato Botelho over 6 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF