Project

General

Profile

Actions

Bug #11452

closed

pkg breakage related to yet to be installed 21.02 base system

Added by Craig Leres about 3 years ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Package System
Target version:
-
Start date:
02/18/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

It would appear merely running "pkg" in the shell of a 2.4.5_1 base system results in:

pkg: Warning: Major OS version upgrade detected. Running "pkg bootstrap -f" recommended

which borks pkg:

pylon 5 # pkg
Shared object "libarchive.so.7" not found, required by "pkg"

I tried to go to the system update page which complete wedged pfsense requiring a reboot.

I was also notified of available package upgrades last night which you do not want to do when an base system updated is pending because that will also bork pkg (see issue [https://redmine.pfsense.org/issues/10464] created 10 months ago...)


Related issues

Related to Todo #10464: Don't change the current update repo when new releases are availableClosedReid Linnemann04/16/2020

Actions
Actions #1

Updated by Jim Pingle about 3 years ago

  • Status changed from New to Duplicate

Part of that is expected (use pkg-static) but the real fix will come with #10464

Actions #2

Updated by Viktor Gurov about 2 years ago

  • Related to Todo #10464: Don't change the current update repo when new releases are available added
Actions

Also available in: Atom PDF