Project

General

Profile

Actions

Bug #11547

closed

DNS Resolver does not bind to an interface when it recovers from a down state

Added by Frank Gouton 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
DNS Resolver
Target version:
Start date:
02/26/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.5.0
Affected Architecture:

Description

Unbound doesn't open a listening socket for an interface that has no active device. If you connect a device later it can't resolve domains.

Steps to reproduce:

Connect a PC directly with a LAN port of the pfsense
Boot the PC up.
Stop DNS Resolver (no reload)
Unplug THE lan cabl
Start the resolver
Wait for start,
Wait some seconds more
Connect PC.

Result: The PC can't resolve DNS
That is a serious problem for me because this happens every morning and I have to reload unbound manually.

This problem was discussed here: https://forum.netgate.com/topic/161400/unbound-stops-listening-on-interface/3

Actions

Also available in: Atom PDF