Project

General

Profile

Bug #11554

Selected Data Encryption Algorithms list items reset when an input validation error occurs

Added by Viktor Gurov about 2 months ago. Updated about 1 month ago.

Status:
Feedback
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
02/26/2021
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.0
Affected Architecture:
Release Notes:
Default

Description

How to reproduce:

1) Open OpenVPN instance for editing
2) Make any input error
3) Fix it and save

Now Data Ciphers for this instance = AES-256-CBC instead of default AES-256-GCM, AES-128-GCM, CHACHA20-POLY1305, AES-256-CBC

Associated revisions

Revision f725132e (diff)
Added by Viktor Gurov about 1 month ago

OpenVPN ncp_enable checkbox fix. Issue #11554

Revision c68bc678 (diff)
Added by Viktor Gurov about 1 month ago

OpenVPN ncp_enable checkbox fix. Issue #11554

(cherry picked from commit f725132eac3d6dbada8b7bc48effdf768fccb341)

History

#1 Updated by Jim Pingle about 2 months ago

  • Target version set to CE-Next

#3 Updated by Jim Pingle about 2 months ago

  • Status changed from New to Pull Request Review

#4 Updated by Renato Botelho about 1 month ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Viktor Gurov

PR has been merged. Thanks!

#5 Updated by Danilo Zrenjanin about 1 month ago

  • Status changed from Feedback to Resolved

Tested on the latest release. The issue is fixed.

Ticket resolved.

#6 Updated by Jim Pingle about 1 month ago

  • Status changed from Resolved to Waiting on Merge
  • Target version changed from CE-Next to 2.5.1

#7 Updated by Renato Botelho about 1 month ago

  • Status changed from Waiting on Merge to Feedback

Cherry-picked to RELENG_2_5_1

#8 Updated by Jim Pingle about 1 month ago

  • Subject changed from Data Ciphers value resets on input validation error to Selected Data Encryption Algorithms list items reset when an input validation error occurs

Updating subject for release notes.

Also available in: Atom PDF